Erreur durant l'installation Drupal 7.12 [Fr]

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

Je souhaite installer Drupal 7 et me familiariser avec ce CMS,
lors de l'installation de Drupal 7 fr, téléchargé sur ce site,
j'ai l'erreur suivante et je ne sais pas comment résoudre cela :

Erreur à l'importation de la traduction
An AJAX HTTP error occurred. HTTP Result Code: 200 Debugging information follows. Path: http://localhost/site_drupal/install.php?profile=standard&locale=fr&id=2... StatusText: OK ResponseText: ( ! ) Fatal error: Maximum execution time of 30 seconds exceeded in D:\wamp\www\site_drupal\includes\database\database.inc on line 2139 Call Stack #TimeMemoryFunctionLocation 10.0008678664{main}( )..\install.php:0 20.00621266360install_drupal( )..\install.php:26 31.125313831240install_run_tasks( )..\install.core.inc:79 42.115628549208install_run_task( )..\install.core.inc:342 52.158228702040_batch_page( )..\install.core.inc:452 62.158828714640_batch_do( )..\batch.inc:80 72.158828714640_batch_process( )..\batch.inc:161 82.174928836464call_user_func_array ( )..\batch.inc:284 92.174928836496_locale_batch_import( )..\batch.inc:284 102.175028837824_locale_import_read_po( )..\locale.inc:2297 1129.944928855600_locale_import_one_string( )..\locale.inc:761 1229.945028855760_locale_import_one_string_db( )..\locale.inc:1030 1329.994828860056InsertQuery_mysql->execute( )..\locale.inc:1134 1429.994928861112DatabaseConnection->query( )..\query.inc:36 1529.994928864168DatabaseStatementBase->execute( )..\database.inc:664

Merci de votre aide !

Forum : 
Version de Drupal : 

J'ai modifier les paramètres du fichier PHP.ini de mon Wampserver et cela ne change pas,
je ne comprends pas ...

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

; Maximum execution time of each script, in seconds
; http://php.net/max-execution-time
; Note: This directive is hardcoded to 0 for the CLI SAPI
; max_execution_time = 30
max_execution_time = 180

; Maximum amount of time each script may spend parsing request data. It's a good
; idea to limit this time on productions servers in order to eliminate unexpectedly
; long running scripts.
; Note: This directive is hardcoded to -1 for the CLI SAPI
; Default Value: -1 (Unlimited)
; Development Value: 60 (60 seconds)
; Production Value: 60 (60 seconds)
; http://php.net/max-input-time
; max_input_time = 60
max_input_time = 180

; Maximum input variable nesting level
; http://php.net/max-input-nesting-level
;max_input_nesting_level = 64

; Maximum amount of memory a script may consume (128MB)
; http://php.net/memory-limit
; memory_limit = 128M
memory_limit = 256M

Bonsoir,

bizarre... as-tu relancé le serveur après avoir modifié les paramètres ?
Si ça ne passe toujours pas, tu peux augmenter la valeur.

Est-ce qu'il y aurait des indications dans les fichiers de logs de apache ? (access.log ou error.log)

Oui j'ai relancé le serveur après avoir fait mes modif du fichier php.ini pour quelles soient prise en compte.

Du coup j' ai pas tout de traduit ... normale vue que ça plante.

un autre truc bizarre, c'est lorsque je crée une page type erreur-404 via (contenu -> +Ajout de contenu -> Page de base -> Créer page de base et que je renseigne les champs Titre et Body -> et que je créé l'alias d'URL en nommant erreur-404 dans les paramètres des chemin d'URL et que j'enregistre.
Puis je vais dans Configuration -> système -> information -> dans le bas de la page dans l'encadré ERROR PAGES, j'indique l'alias que j'ai créé erreur-404 pour le champ Page 404 par défaut et que j'enregistre tout ça, puis je reviens sur l’accueil et dans le champ d'url du navigateur je tape après le / toto pour tester j'suis redirigé sur la page localhost de mon wampserver et non sur la page erreur-404, c'est étrange ...
Je ne comprends pourquoi ?

Lien Mon fichier access.log

Lien Mon fichier apache_error.log

Dans le noyau de DRUPAL, le fichier includes\locale.inc définit la fonction _locale_import_po($file, $langcode, $mode, $group = NULL) avec l’instruction drupal_set_time_limit(240);

C’est ce 240 qui est sous-dimensionné. 4 min, ce n’est pas suffisant. Il y a d’ailleurs un gentil commentaire qui nous prévient : "// Try to allocate enough time to parse and import the data."

Sur ma conf. locale, il me faut environ 15 min pour importer la totalité de la traduction contenue dans le fichier drupal-7.0.fr.po. J’ai donc mis 900 comme valeur à la place du 240 pour obtenir une traduction complète (99,98%).

il faut aussi changé la valeur dans le module l10n_update : l10n_update.locale.inc
à la ligne 28 : drupal_set_time_limit(240) ;

Merci pour ta réponse, finalement j'ai continué l'installation de drupal 7.12 malgrès l'erreur, et ensuite dans les parametres du site, j'ai importé la traduction en lui laissant le temps de finir (à peu près 10minutes) et j'ai une traduction à 92% qui me convient déjà bien.

Bonjour,

J'ai eu le même problème lors de l'installation j'avais beau augmenter mon max_execution_time à 9000 ou autre ça ne fonctionnait toujours pas.
Solution :
- se rendre dans \drupal\sites\default
- ouvrir le fichier default.settings.php
- y ajouter la fonction ini_set('max_execution_time', 0); (la ligne 288 est un bon emplacement)

Cela permet d'avoir un execution_time infini, donc plus de problème de timeout.

Bonjour,
Cette fonction sera appelée automatiquement?
Aussi, j'ai eu aucun pb pour installer sur le serveur en ligne. Ce ne serait pas facile de downloader ce qu'il me faut de mon site distant sur localhost avec Filezilla?