Message d'avertissement

The subscription service is currently unavailable. Please try again later.

site inaccessible sauf en administrateur

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour

Je débute sous Dupral et j'ai déjà un soucis :
le site ne s'affiche pas au public avec un navigateur, mais seulement en mode administrateur. Et encore, sans demander de mot de passe ...
J'ai vidé le cache et utilisé plusieurs navigateurs différents. Je cherche depuis hier soir et je trouve pas ...

merci d'avance.

-Z-

Version de Drupal : 

Bonjour,
Tu peux en dire un peu plus sur ce que tu as fait entre le moment où ça marchait et le bug ?
Si tu as installé de nouveaux modules, fait des mises à jour, as-tu pensé à faire un update ? Vérifie aussi que tu ne l'as pas laissé en maintenance…
Jimi

Salut CyberJimi

J'ai donc installé Dupral 6.14 automatiquement via le site OVH
En adminstrateur, J'ai commencé à farfouillé dedans, ajouter des catégories, essayer les thèmes ;..
J'ai ensuite installé 3 modules : wysiwyg - fckeditor - tinymce

Puis j'ai voulu voir ce que donnait le tout, j'ai changé de navigateur et là rien ne marche :
"The server has not found anything matching the request address (URI).
This means the URL you have typed or clicked on is wrong or obsolete and does not match any document existing on the server (you may try to gradualy remove the URL components from de right to the left to eventualy retrieve an existing path).Context of the error
Page requested : /dupral/index.php"

Pas fait de mise à jour, ni de update (d'ailleurs ça se fait où ?)

merci d'avance !

Re

Je viens de refaire l'installation et il existe un problème dans le tableau de bord :

PHP 'register globals' Activé ('1')
La directive register_globals est activée. Drupal nécessite que cette directive soit desactivée. Votre site peut en effet être à risque si register_globals est activée. Vous trouverez les instructions nécessaires pour changer les paramètres de configuration dans le manuel PHP.

... et je comprend rien et ne vois pas où intervenir ...

-Z-

C'est sur ton serveur dans le fichier php.ini que tu dois changer ça. Si n'y as pas accès (si tu est sur un mutualisé) tu peux essayer de bidouiller avec le fichier .htaccess :
http://www.manuelphp.com/php/ini.register-globals.php
Vérifie quand même que ton hébergement te permet de faire fonctionner drupal :
http://www.dator.fr/drupal-installation-du-site/
Tout ça c'est la partie la plus chiante qu'il faut arriver à dépasser. Après Drupal c'est (presque) rien que du bonheur ;-)
Jimi