Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Les url users : Probleme

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous , $

Voila j'ai un probleme.

-Etat : J'ai crée un site musicale et les utilisateurs ont un espace perso , et une fiche les concernant ou ils rentrent leurs infiormations..

-Probleme : l'url de leur fiche est : /user/286 etc etc...
Comment faire pour que cet url soit au nom de leur pseudio??

Mon pseudo est woodye , ma fiche se trouve a cet adresse : http://www.exemple.com/woodye ???

Dites moi qu'il ya une solution s'il vous plait , j'ai esayé le module me , mais rien a faire , je n'y parvient pas..

Merci beaucoup pour l'aide que vous pouvez fournir..

Version de Drupal : 

Salut Woodye,

Voici comment il faut faire :

1) Activer le module path, qui est un module par défaut de Drupal qui te permet de ré-écrire les URL. En gros, c'est ce module qui te permet de ré-écrire "user/286" en "woodye", on appelle ça un "alias d'url". Pour ça, va dans administer » url aliases après avoir activé ce module, et clique sur add alias pour entrer les aliases dont tu as besoin.

2) Comme ça risque d'être fastidieux de répéter cette opération pour chacun de tes utilisateurs, tu peux télécharger et installer le module pathauto qui te permet de générer automatiquement un alias pour chaque page de ton site (qu'il s'agisse d'un utilisateur, d'un node...). Tu verras quand tu l'auras installé, son fonctionnement est très intuitif, mais reviens ici si tu as d'autres questions.

Merci mais j'ai bien fait cela , puis entierement en anglais , tout a changé..

Mais effectivement cela fonctionne mais il y a toujours les "?q=" , n'y a til pas possibilité de les retirer..

Ensuite pour les view , il y a un probleme , les users mettent des musiques et la view recapitule dans "mes titres" , IMPOSSIBLE de mettre l'url avec leur nom d'utilisateur...

Le plus ennuyeux pour le moment est l'url avec le q=user qui fait réference à "mon compte"...

Il faudrait pour exemple wooodye :

http://www.exemple.com/wooodye et non http://www.exemple.com/?q=wooodye

Est ce possible?

Merci encore

Hello woodie,

Pour ton problème de View, je n'ai pas compris.

Pour que les utilisateurs puissent accéder à leur compte autrement que via q=user, il y a le module me alias qui peut peut-être t'aider.

Enfin, pour supprimer le "q=", il faut activer les url simplifiées ("clean urls" en anglais) dans administer > settings. Note que mod_rewrite doit être activé sur ton serveur pour que ça fonctionne.