Message d'avertissement

The subscription service is currently unavailable. Please try again later.

[résolu] disparition du menu d'administration drupal

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

bonjour à tout le monde,

je débute dans drupal, et en ajoutant et activant des modules mon menu d'administration à disparu, donc meme connecté en administrateur, je ne peux des lors plus que créer ou supprimer des pages, je n'ai plus d'accès pour activer ou non mes modules ...

pouvez vous m'expliquer comment retrouver mon menu ??

merci d'avance

zerOwhite

Version de Drupal : 

en tapant http://monsite/admin

(mon site est hébergé chez 1and1)

j'ai le message suivant qui s'affiche :

Error 500 - Internal server error

Un problème inattendu est survenu.
Veuillez réessayer ultérieurement.

svp dit moi qu'il y a un moyen simple de régler cela sans réinstaller complétement drupal :s

merci pour ton aide

Bonjour,

le module 'admin-menu' joue à cache-cache avec certains thèmes (ex: chrysalis).
Il désactive le menu d'administration dans le menu général 'Navigation'
(c'est son but) mais il arrive que le menu d'administration
au dessus du thème disparaisse quand on installe ou désinstalle d'autres modules.

En désinstallant 'admin-menu' tout rentre dans l'ordre après une reconnexion.

je crois que j'ai fint une boulette !!

j'ai supprimer le dossier admin dans "sites\all\modules"

croyant que c'était le module "admin-menu", ce qui à fait disparaitre toute l'interface de mon site même après remise du dossier depuis mon pc sur le serveur

docteur est-ce grave ??

peut etre qu'ils font la maintenance de leur serveur, Je ne crois pas qu'il faut réinitialiser.
mais je sais que c'est le chemin d'accès au menu d'admiistration.

Dès que tu le verras afficher, pense à installer le module "admin menu" il te servira comme menu d'administration

bon j'ai mon site de nouveau correctement en ligne mais toujours pas d'accès à la partie admin du menu, donc je ne vois pas comment activer le module "admin-menu" que je viens d'ajouter sur le serveur ???

y a t'il un moyen de l'activer en modifiant un fichier de config ou quelque chose comme cela ?

'comprends pas bien ton problème : ton menu "navigation" (celui à partir duquel tu administres) a disparu de l'écran, ou bien la barre noire en haut de l'écran contenant le menu créé par le module admin_menu a disparu ? Ce sont deux choses différentes... Et qu'appelles-tu "la partie admin du menu" ?? donne plutôt l'adresse de la page ...

C'est toi qui a créé ce menu "navigation" à gauche ?

(ps. y'a un problème avec ton fichier attaché, non ?)

(pps. donne l'adresse de ce que tu appelles "la partie admin du menu" ! tu veux dire .../admin, .../admin/build/... ???)

à cet endroit j'ai de-nouveau accès à tout l'administration de drupal !!

merci pour ton aide j'ai bien pris notes des adresses que tu m'a donné je vais voir pour refaire mas partie de navigation

merci beaucoup

je vais mettre le sujet en résolu tout de suite

merci encore

si tu ne réponds pas aux questions que je te pose, je ne vais pas pouvoir t'aider. Je n'arrive pas à comprendre ce que tu as fait ; apparemment tu as créé un autre menu qui s'appelle navigation ; or le menu principal de Drupal, celui à partir duquel tu administres le site, et qui dans l'affichage porte ton nom d'utilisateur, s'appelle "navigation". donc si tu as créé un deuxième menu avec ce nom, il est probable qu'il y ait conflit dans l'affichage des blocs (il affiche le "mauvais" bloc, celui de ton menu et pas le "vrai" menu navigation). Pour en être sûr, SUPPRIME le menu que tu as créé et vérifie que l'autre est bien réapparu. Dans ce cas, tu peux recréer un autre menu MAIS NE L'APPELLE PAS "navigation". Tu activeras le bloc correspondant pour le faire apparaitre, et Drupal ne confondra pas les deux.

Si tu n'as pas créé de menu qui s'appelle "navigation", c'est que le problème vient d'ailleurs.

en fait je ne sais pas exactement comment te répondre, je e connais pas encore tout le vocabulaire de drupal, et comme je ne m'y suis mis que hier, je n'ai pas encore suivi tous les tutos

alors je viens de vérifier, je n'ai pas de bloc qui s'appelle navigation, je suppose avec ma faible connaissance, que le soucis à du venir d'un module mal configuré, j'ai donc ré-afficher les bons bloc et j'accède de nouveau à tout ce dont j'ai besoin d'accéder pour administrer mon site via drupal,

c'est vrai qu'a la première prise en main ce n'est pas ce qu'il y a de plus facile
mais ça à l'air tellement puissant que je vais tout faire pour le maitriser

j'espère avoir été clair dans ma réponse, sinon je me ferais un plaisir d'éclaircir les parties obscures

merci encore pour ton aide Marie-Hélène

Que tu démarres j'ai bien compris, mais quand je te demande quels sont les menus que tu vois sur la page d'administration des menus donne-moi la liste des menus que tu vois sur la page d'administration des menus...

Je ne suis pas sûre d'avoir compris quel avait été ton problème, mais si tu as retrouvé tout ton monde, tant mieux.
Bonne soirée.