Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Le module Wysiwyg

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Salut a tous

Je cherche un editeur Wysiwyg sous drupal et je suis tombé sur le module Wysiwyg qui permet d'installer tout les éditeurs Wysiwyg (TinyMCE, CK editor, etc...). J'installe donc le module, je l'active, je choisis TinyMCE, dans Configuration du site -> Wysiwyg, il y a les choix suivants :

  • Filtered HTML : Editeur à choisir
  • Full HTML : Editeur à choisir

Je mets les 2 à TinyMCE.

Lorsque je veux écrire un contenu, l'éditeur n'apparait pas, que faire ?

merci

As-tu choisir "fr" dans les langues de l'éditeur ? Auquel cas il doit y avoir le langague pack équivalent d'installé dans tinymce. Le cas échéant, l'éditeur meure silencieusement. Je ne vois pas d'autre raison dans mon stock d'emmerdements avec TinyMCE :)

Je viens de choisir fr... sans succès. Cela vient peut etre du module WYSIWYG.
Pour utiliser TinyMCE, il faut bien (après activation) juste aller dans "créer un contenu" et cocher l'item "Full HTML" ?

Non, justement, il faut le laisser en "en". Vérifie que tu as bien coché "activé par défaut" et passe éventuellement voir la section CSS : là tu mets "CCS par défaut de l'éditeur". J'espère que tu vas trouver, je ne comprends pas ton problème.

Bonjour,

Effectivement, les cas similaires que j'ai rencontrés venaient du fait d'avoir choisi une autre langue que "en".

Mais moi, à propos de ce module wysiwyg, j'ai une autre question qui peut vous paraître saugrenue :

Faut-il l'utiliser ou pas ? En effet, le module "fckeditor" que j'utilisais avant pour intégrer FCKeditor semble toujours vivre et il est précisé qu'il n'est pas affilié à "wysiwyg". Alors, la tendance du futur plaide-t-elle pour wysiwyg ou peut-on (doit-on ?) continuer à utiliser les anciens modules ?

Je relance ce sujet car je me sui heurté au même problème des mois plus tard.
Il faut oublier la localisation de TinyMCE et rester en "en".

J'ai quant à moi eu une expérience supplémentaire : après avoir installé TynMCE et l'avoir passé en "fr" (cru l'avoir fait en tout cas), tous mes contenus d'articles ont perdu leur accentuation, comme s'ils avaient perdu leur codage utf8 (accents remplacés par symboles : é pour é...).

Quelqu'un d'autre a-t-il eu la même expérience ? Et quelqu'un a-t-il une solution ? voici deux jours que je perds sur ce truc sans trouver d'issue.
Merci

Bonjour,

Je pense avoir une solution à ton problème.

Pour INFO :

J'utilise :
Windows XP SP3 -
WampServer -
Drupal 6.20, Wysiwyg 6.x-2.2 - que j'ai placé dans : "sites\all\modules\wysiwyg"
et l'éditeur : "tinymce_3_3_9_3.zip" que j'ai dézippé et copié dans : "sites\all\libraries\tinymce"

Voici :

1) Télécharge, dézippe et place le module "wysiwyg" dans "sites\all\modules\wysiwyg".

2) Après avoir activé le module wysiwyg, (Menu Admin : Construction du site - Modules - Lister - Coche "wysiwyg" et Cnregistre),
3) tu vas sur la page "Profils wysiwyg" (Menu Admin : Configuration du site - Profils wysiwyg - Lister).

4) Là, il te propose de télécharger un éditeur(dans cet exeple-ci : tinymce ou mais ça peut être un autre proposé). C'est ce que j'ai fait et je l'ai dézippé et placé dans : "sites\all\libraries\tinymce" (si le dossier "libraries" n'existe pas encore, il faut le créer)

5) Quand tu es sur la page "Profils wysiwyg", tu as un tableau où tu vois un titre au-dessus de chaque colonne :

"Format d'entrée" - "Editeur" - "Opérations"

Donc :

6) Tu choisis l'Editeur que tu as installé, pour un format d'entrée de ton choix.
(Je pense que c'est ce que tu as déjà fait).

7) Une fois que tu as choisi l'Editeur pour ton "Format d'entrée", un lien "Modifier" apparaît à droite du tableau dans la colonne "Opérations".

8) Un clic la dessus te mène à la page de Configuration de ton format d'entrée et, l'onglet "Modifier" est actif par défaut. (Sans doute l'as-tu déjà fait aussi).

9) Maintenant, il faut tout simplement cliquer sur le lien "Boutons et Plugins" et choisir ce dont tu as besoin pour ton Editeur.

10) Ton choix étant fait, Enregistre tout cela avec le bouton "Enregistrer" en bas à 1/3 gauche.

11) Maintenant, si tu retourne à une page d'édition(1) de ton choix (Menu Admin: Gestion de Contenu/Créer un Contenu/...) et après avoir choisis ton format d'entrée(Clique sur le Lien "Format d'entrée" (juste sous l'Editeur) et choisis ton format d'entrée que tu viens de configurer), normalement, tu devrais voir apparaître ton éditeur et les boutons et plugins choisés.

(1): Fais-le sous superAdmin, sinon tu risque d'avoir le problème de "Droit d'Accès".

[Si tu veux donner le droit d'accès de ton éditeur aux autres utilisateurs,
Comment faire ? :
Il faut aller dans le Menu Admin: Configuration du Site/Format d'entrée/(lien)Configurer de ton format d'entrée/(élément)Rôle(où tu coches : utilisateur anonyme et/ou utilisateur enregistré).]

@+

Drupalophile

Bonjour,
J'ai également pas mal galéré sur la disparition des boutons (ils apparaissaient avant pour moi sous drupal 6, et lors du passage D7 ils ont disparu...). Je suis sous CKEditor, mais la résolution du problème reste la même.

En fait, ce n'était pas un problème de langues, mais de droits :
un de mes répertoires (vérifier les modules ainsi que la bibliothèque library) n'était plus en lecture/exécution (chmod 744).

Il m'a fallu remettre ces droits, désactiver ces modules, un update.php et re-installer les modules (c'est assez rapide).

Maintenant ça marche :-)