Message d'avertissement

The subscription service is currently unavailable. Please try again later.

[résolu] Problème de mise à jour Image Assist

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

J'ai mis à jour le module Image 6.x-1.0-alpha6 tout bien, puis j'ai essayé de mettre à jour Image Assist 6.x-2.0-alpha3. En apparence tout fonctionne, sauf qu'au moment de cliquer sur "Insérer" pour déposer l'image dans FCKeditor rien ne se passe et la fenêtre d'Image Assist reste ouverte, vide.

Je n'utilise que FCKeditor + Image Assist, rien d'autre, pas de Wysiwyg.
Je me demande si le problème n'est pas là.

En comparant les deux versions du module Image Assist, vers la ligne 573 on a...

img_assist.module,v 1.75.2.26 2009/02/13

function img_assist_loader() {
  $path = drupal_get_path('module', 'img_assist');
  $editor = arg(2) ? arg(2) : 'textarea';

  drupal_add_js($path .'/img_assist_popup.js');
  if ($editor == 'tinymce') {
    $tinymce_path = drupal_get_path('module', 'wysiwyg');
    drupal_add_js($tinymce_path .'/tinymce/jscripts/tiny_mce/tiny_mce_popup.js');
  }
  drupal_add_js($path .'/img_assist_'. $editor .'.js');

qui devient...

img_assist.module,v 1.75.2.31 2009/07/15

function img_assist_loader() {
  $path = drupal_get_path('module', 'img_assist');
  $caller = arg(2) ? arg(2) : 'textarea';

  drupal_add_js($path . '/img_assist_popup.js');
  if (module_exists('wysiwyg') && ($editor = wysiwyg_get_editor($caller))) {
    if ($editor['name'] == 'tinymce') {
      drupal_add_js($editor['library path'] . '/tiny_mce_popup.js');
    }
  }
  elseif (module_exists('tinymce') && $caller == 'tinymce') {
    drupal_add_js(drupal_get_path('module', 'tinymce') . '/tinymce/jscripts/tiny_mce/tiny_mce_popup.js');
  }
  else {
    $caller = 'textarea';
  }
  drupal_add_js($path . '/img_assist_' . $caller . '.js');

Si je comprends bien, si ce n'est pas tinymce l'éditeur, il considère que c'est un simple textarea. Pas de bol si c'est fckeditor !

Il faudrait peut-être que je change le code au niveau du else pour

elseif ($caller != 'fckeditor') {
    $caller = 'textarea';
  }

Non?

Version de Drupal : 

Merci beaucoup pour ce post, ça m'a évité des heures de recherches, peut-être ! J'en ai profité pour m'inscrire ici.
Et oui, j'espère qu'ils garderont la possibilité d'utiliser fckeditor plus simplement... c'est d'ailleurs écrit dans le commentaire du code à modifier ici.