Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Problème "liste des modules"

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour, tout le monde.

Voila je viens vers vous car j'ai un soucis, depuis peu, que j'arrive pas à résoudre.

Lorsque je veux allez dans ma liste de modules installé, il me répond un message d'érreur :

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 562644 bytes) in /mon/chemin/www/includes/database.mysql.inc on line 301

Du coup je suis relativement bloqué. Qui à une idée de comment débloqué tous ça.

Amicalement

leonidas

Version de Drupal : 

C'est un probleme récurrent de drupal : en listant des blocs, des modules ou des droits d'accès; on explose le paramètre memory limit de php. La seule solution c'est :
en local : modifier le paramètre memory_limit dans ton fichier configuration de php
en ligne : heu... changer d'hébergeur ? en général ils sont pas très chauds pour augmenter ce paramètre.

En plus depuis que j'ai fait un upgrade en 6x depuis un 5x, ça rame mais grave.

Tout est au vert, sauf ImageAPI GD Memory Limit 32M,

Sinon, OVH ma répondu qu'il n'upgradé pas la mémoire php. Donc je reste avec
"Plafond mémoire de PHP 32M".

Mais je sais pas si c'est drupal, qui rame. Pourtant j'ai fait l'install comme d'habitude.J'ai du mal à administrer mon drupal, car ça fait genre 56K de l'époque.

J'ai fait toutes les mise à jours le poormascron fonctionne, je ne sais plus vraiment trop quoi faire.

Bonjour à tous!

je suis dans la même "galère" que toi!

J'ai une "maquette" en ligne, avec quelques pages pour "construire" ce que j'avais mis sur une feuille...
Et me voici avec...
Fatal error:
Out of memory (allocated 32768000) (tried to allocate 926162 bytes) in /homepages/18/d285877941/htdocs/includes/database.mysql-common.inc on line 41

Je bosse depuis quelques heurs dessus,
j'ai fouillé "toutes" (???) les soluces pour augmenter la mémoires...
(modif du setting.php, ajout d'1 php.ini...)
le phpinfo() me donne après mes bidouilles:

memory_limit 128M 128M
open_basedir no value no value
output_buffering 0 0
output_handler no value no value
post_max_size 32M 32M

l'hébergeur, lui se limite "réellement" à 32M... (1&1).

Ce qui me met en "rogne", c'est que j'ai "refondu" un site sous joomla15
et sur 1 hebergement "gratuit"!!
"ça tourne", jce editor est un "petit bijou"...
Mais c'est trop "fermé" pour le développement prévu...

Pour en revenir à mon problème:
j'ai installé la version "acquia", un theme "newflash" (non modifié!!)
fckeditor, pas de gallery "externe", les modules me semblent à jour
j'ai vidé le cache... fais un "update.php"...
Viré "physiquement" les modules "qui me semblent(!)" non utiles (en tous cas non "activés")...
il y a 10 ou 15 pages, 3 views, 2 webform...
Et déjà planté...

Je ne peux pas reprendre la main...

Si vous avez une idée...

Amicalement

Ouf...
J'ai repris la main...
(pour combien de temps?)

J'ai updaté le cck (de 6.23 à 6.24 date 19/06/09).
AUcun autre update dans le statut report(merci pour le tag!), tout est au vert,
il me trouve bien 100M!

MySQL database 5.0.81
PHP 5.2.9
PHP memory limit 100M
PHP register globals Désactivé

La page liste des modules s'est affichée, j'ai décoché:
le menu, les help (+avancée+ exemple)

1 minute de moulinette, et c'est revenu.

Est-ce la version acquia qui est "très gourmande"?
il ne semble pas y avoir de différence dans l'install (6.12), et
ce qui m'a fait choisir, ce sont le s modules "présents", ce qui évie pas mal de
manips
ù
Voilà.
Je suis quand même "un peu inquiet", car j'en suis à 15% pour la construction.

Amicalement

En ce qui me concerne, j'ai eu le même problème et je pense l'attribuer au fait que j'ai validé trop de modules à la fois.

J'en étais au début de l'installation, donc j'ai effacé le fichier settings, je l'ai rechargé sur le serveur et j'ai recommencé l'installation en attribuant un nouveau nom à la database... Ça, après coup, je regrette, parce que j'aurais pu "écraser" l'ancienne puisqu'elle ne sert plus à rien...