Message d'avertissement

The subscription service is currently unavailable. Please try again later.

probleme installation : configuration de la base de donnees

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour a tous,

je suis en train d'installer Drupal 6.x sur mon pc. Je suis le guide d'installation de Drupal. Arrive le moment ou je dois configurer la base de donnees. A ce moment, je met "Drupal" comme base de données (base vide que j'ai créé sous easyphp) et mon login (qui a tous les privileges) et mot de passe. J'appuis sur le bouton de validation mais rien ne se passe. Quand j'essaye de me connecter en root, j'ai un message d'erreur suivant :

Impossible de se connecter à votre serveur MySQL. MySQL a répondu : .

* Etes-vous d'avoir fourni le bon nom d'utilisateur et mot de passe ?
* Avez-vous bien saisi le nom d'hôte du serveur ?
* Etes-vous sûr que le serveur est actuellement démarré ?

Mon serveur est bien démarré et je n'ai pas modifié le nom d'hote. je pense que c'est probablement le mot de passe qui est pas correct car j'en suis pas sur a 100%.

Que faire pour me debloquer?

Merci d'avance!

Version de Drupal : 

Bonjour,
ça dépend un peu de la version easyphp que tu as installée.
En local, sous easyphp 3, si tu n'as rien changé aux paramètres par défaut, l'utilisateur est "root" et le mot de passe est "mysql".

merci pour ta reponse. J'ai easyphp 3 et je pense n'avoir rien changé au mot de passe par defaut de root. Je fais donc "drupal" pour la base de données et "root"/"mysql" puis je valide... Et j'ai le meme resultat qu'avec mon compte utilisateur : ca bloque sur la meme page. Peut etre est ce un probleme avec la base de donnees elle meme?

Question idiote tu fais attention à la casse quand tu tape le nom de ta base ?
J'ai vu que tu a mis une fois Drupal et sur le post suivant drupal.
Sinon tu peut modifier ton mot de passe root pour être sur de ton coup.

J'ai ceci dans settings.php :

$db_url = 'mysql://username:password@localhost/databasename';
$db_prefix = '';

je l'ai remplace par ce que tu m avais dit :

$db_url = 'mysqli://root:mysql@localhost/drupal';
$db_prefix = '';

je sauve.

je relance drupal et ca plante avec le message suivant :

Warning: in C:\Program Files\EasyPHP 3.0\www\drupal-6.12\includes\database.mysqli.inc on line 128

Warning: Duplicata du champ '' pour la clef 'name' query: INSERT INTO users (name, mail) VALUES('', '') in C:\Program Files\EasyPHP 3.0\www\drupal-6.12\includes\database.mysqli.inc on line 128

Warning: Duplicata du champ 'placeholder-for-uid-1' pour la clef 'name' query: INSERT INTO users (name, mail, created, data) VALUES('placeholder-for-uid-1', 'placeholder-for-uid-1', 1244457997, 'a:0:{}') in C:\Program Files\EasyPHP 3.0\www\drupal-6.12\includes\database.mysqli.inc on line 128

Warning: Duplicata du champ 'anonymous user' pour la clef 'name' query: INSERT INTO role (name) VALUES ('anonymous user') in C:\Program Files\EasyPHP 3.0\www\drupal-6.12\includes\database.mysqli.inc on line 128

(...)

j'ai pas tout mis car c'est long. Quelqu'un peut il me dire quoi faire svp?

merci!

Edit: j'ai tout relancé une nouvelle fois et j'obtiens un autre message d'erreur qui est le suivant :

Home

* user warning: in C:\Program Files\EasyPHP 3.0\www\drupal-6.12\includes\menu.inc on line 315.
* user warning: in C:\Program Files\EasyPHP 3.0\www\drupal-6.12\includes\menu.inc on line 315.

Pouvez vous m aider svp? merci!

J'ai remis dans settings.php:

$db_url = 'mysqli://root:mysql@localhost/drupal';
$db_prefix = '';

J'ai relancé et je suis retombé sur :

Home

* user warning: in C:\Program Files\EasyPHP 3.0\www\drupal-6.12\includes\menu.inc on line 315.
* user warning: in C:\Program Files\EasyPHP 3.0\www\drupal-6.12\includes\menu.inc on line 315.

Que faire?

Merci!

Je viens de faire un test avec la même config que toi.
j' ai téléchargé easyphp3.
- puis création d'un base 'drupal'
- copie du contenu du dossier drupal 6.12 vers un dossier 'monsite'
- copie du fichier default.settings.php vers settings.php
- à l'install: base = drupal
login = root
pass = mysql

et tout à bien marché.
Compte tenu que tu n'as encore rien rentré dans ta base à ta place je ferai un clean install.

Désinstalle easyphp, n'oublie pas de supprimer tout les dossiers et fichiers que la désinstallation ne supprime pas et recommence de zero.

Oui je sais c'est un peu radicale comme solution mais bon au moins on part sur une base saine.;-)
D'apres le test que je viens de faire tu n'aurais pas du avoir de problemes.
Quand tu copie le dossier drupal n(hesite pas à le renommer avant de lancer l'install. C'est plus sympa d'avoir http://127.0.0.7/monsite que http://127.0.0.7/drupal-6.12

merci pour vos reponses. je vais voir ce que je peux faire.

Alex

edit : j'ai effacé ma base de données druptal, j'ai recréé une base de données druptal et j'ai recommencé et la ca a marché!

Merci beaucoup pour votre aide!

Alex

petite question subsidiaire : j'ai installé drupal en francais mais mon interface reste en anglais. Comment faire pour avoir l'interface en francais sachant que je suis deja allé dans administer/languages et que la case fr qui est cochée est grisée et quón ne peut pas modifier le langage.

Merci pour vos réponses.