Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Pb FckEditor : pas de bouton "parcourir le serveur"

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Salut à tous !

Bon, mon pb est résumé dans le titre, je crois. :-))
J'ai eu beau aller tripatouiller dans le fichier de config de fckeditor, impossible d'uploader une image dans un article depuis mon disque. Quand je clique sur "insérer une image", pas de "parcourir le serveur", ni d'onglet "upload".
Même si je mets l'image "à la main", donc avec son chemin relatif, elle apparait bien dans l'editeur FCK, mais quand j'enregistre la page, elle n'apparait pas dans l'article.
Je suis en Drupal 6, en local pour le moment, avec Wamp.
Je dois avoir un pb de config, ça ne marche avec aucun éditeur Wysiwyg, je ne comprends plus rien... Et je m'arrache les cheveux là-dessus depuis 2 semaines...

Est-il besoin de préciser que je suis débutante en Drupal ? :-))

Merci d'avance pour votre aide !
A bientôt !

Version de Drupal : 

Salut et merci pour ta réponse !

Ben justement, je ne vois pas où je peux configurer ça. Dans les droits d'accès, fckeditor n'apparait nulle part, je n'ai pas non plus accès à admin>settings>fckeditor...

Alors du coup non, je ne l'ai pas configuré, mais je ne vois pas par où le faire... Argh !!!! :-))

Tu devrais trouver ça dans : /admin/user/permissions

Section fckeditor module. Pour un compte admin les permissions devraient toutes être cochées (access / administer et allow fckeditor file uploads)... Par contre justement, il est vraiment nécessaire créer ce profil admin pour assurer le bon fonctionnement de FCK. FCK n'a pas l'air d'apprécier beaucoup le role de supadmin.

Comme justement expliqué dans l'article


Il est indispensable d'avoir des roles définis. Car en effet la configuration de FCK editor, demande une liaison vers un ou plusieurs roles. Ca peut paraître totalement ridicule, mais le role d'admin sur un site drupal est un super role et n'appartient donc à aucun role défini. Il est donc impossible de configurer l'upload pour ce compte. Vous devez créer un role particulier admin qui aura tous les droits, et vous pouvez oublier le role d'origine qui ne sera plus là que pour faire joli :) Comment ça, c'est piégeux ? :p

Je regarde ça de chez moi ce soir, et je te dis si ça fonctionne.

Mis il me semble que tous les droits d'accès de tous les modules sont activés pour le rôle admin, mais que il n'y a pas de droit d'accès particuliers pour fck. Je vérifie ce soir.
Merci en tous cas pour ta réponse, je revis ^^.

Pas de souci ;)

Si jamais la configuration des permissions est bien faite correctement. Tu devrais avoir FCKeditor dans "Site configuration" en étant connectée sous ce profil "admin" (admin/settings/fckeditor). Dans cet onglet tu auras toute la configuration propre à ce module.

Je ne l'ai pas sous le nez, mais je suis quasiment certaine de ne pas avoir vu ça... Suis-je bien connectée en admin et pas en user, alors, du coup ? Ca expliquerait le souci, non ? Mais je croyais avoir mis le role admin à mon user...

Coucou !

Bon, alors, mon user a bien le rôle admin, donc, ça à vue de nez, ça roule. (bahiakal : actif : role admin dans admin/user/user, j'ai bon ?)
Mais dans les permissions d'accès, tout est coché, que ce soit pour user identifié ou admin. Mais pas de fckeditor. J'ai "block, book, comment, contact, content, devel, filter, image, locale, menu, node, path, quicktabs, system, taxonomy, upload, user, webform". Et pis c'est tout. :'((
Franchement, je comprends plus rien. Par là, j'ai pas non plus accès aux droit de IMCE, qui apparaît pas non plus. Je comprends pas pkoi certains modules que j'installe apparaissent, et d'autres non.

Je vais pas tarder à devenir chauve... :-))

salut , je lisait ton Post ..
car j'ai aussi des Pb avec Fckeditor , ...
As tu esssayé de le désinstaller et réinstaller , par le menu Modules.

Sinon , tu peux essayer par le bias d'une mise à jour fictive du modules , moi ça m'a débloquer un module de cette façon.

Bonsoir,

Tu devrais avoir dans Gestion des utilisateurs > Droits d'accès
 module fckeditor
 access fckeditor
 administer fckeditor
 allow fckeditor file uploads

Et aussi une entrée Configuration du site > FCKeditor

Sinon, c'est que ton instal n'a pas fonctionné.

Pour installer FCKeditor (tout seul), il faut bien :
- télécharger le module sur http://drupal.org/project/fckeditor
- décompresser l'archive .tar.gz pour obtenir un répertoire fckeditor (n°1)
- ouvrir ce répertoire : il contient un second répertoire fckeditor (n°2)
- ouvrir ce répertoire : il est presque vide, à l'exception d'un fichier COPY_HERE.txt
- télécharger FCKeditor lui-même sur http://www.fckeditor.net/download
- décompresser l'archive pour obtenir un troisième répertoire fckeditor (n°3)
- déplacer son contenu vers le répertoire fckeditor (n°2), à côté du fichier COPY_HERE.txt
- transférer le répertoire fckeditor (n°1) dans ton drupal\sites\all\modules
- activer le module FCKeditor

Oulà, effectivement, j'ai dû me rater à l'install, j'ai pas fait tout ça ! ^^

Je vais tenter tout ça. Je vous tiens au jus.

Sinon, oui, j'avais tenté une désinstall et une réinstall, mais manifestement, il me manquait des étapes.

Bon, je garantis pas que je m'y mette ce soir, mais au pire vendredi, je reviens pleurer ou déboucher un champ' virtuel avec vous.

En tous cas, merci de votre aide à tous. (je le répéterai jamais assez, na !) ^^

Bon, à part des pb de connecteurs, mais ça je me débrouillerai (enfin j'espère, arf), ça a l'air de rouler, j'ai récupéré mes boutons d'upload ;-))

Par contre, un truc tout con : quand je crée un contenu, je me retrouve avec 2 versions de fckeditor ds la même page pour alimenter : la version qui marche pas, et la version qui marche, l'une sous l'autre !!! C'est ouak ce délire ??? La fatigue aidant, je vois pas, là... Faut que je la désactive ailleurs ?

Bon, j'ai rien dit, faut juste dire "no editor" dans la partie wysiwyg, en fait.

Chose promise, chose dûe, merci encore à tous de m'avoir dépatouillé si rapidement, et si efficacement.

Et champagne !!! (le caviar, ça sera pour les connecteurs, lol)