Pourquoi mes profils ne peuvent pas utiliser l'éditeur wysiwyg en écriture ?

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,

J'ai installé le module Wysiwig et configuré les éditeurs. J'ai paramétré le menu "Format d'entrée" (filtred input) et donné accès aux profils souhaités.

D'après ce que j'ai compris de Drupal ça devrait suffir non ?

  • L'éditeur Wysiwig est paramétré pour utiliser un éditeur
  • Le format d'entrée autorise tous les profils
  • J'ai donné l'accès à l'administration des filtres

Rien à faire, lorsque mon utilisateur avec un profil donné se connecte, il ne peux pas modifier le texte dans l'éditeur wysiwyg. Je dois le désactiver en cliquant sur le lien "disable richt-text"

Je pige pas ! Dés fois, j'ai l'impression que drupal est surnaturel, genre le truc magique qui marche dés fois et d'autres fois je passe des heures à faire un truc simple. J'espère que quelqu'un prendra le temps de me répondre...

Bonjour,

Je suis sous linux, je fais mes tests avec deux navigateurs (firefox et konqueror).

En administrateur, ça fonctionne bien. J'ai passé 3h sur ce problème je n'ai toujours pas la solution.

Merci de vos conseils.

bonjour
meme probleme sur drupal 7

j'ai testé avec différents modules ckeditor ou wysiwig, différentes librairies (ckeditor ou tinymce)
mon éditeur s'affiche bien sur le profil admin mais pas les autres
voila!

Ce pb remonte à longtemps mais si je me souviens bien, c'était un gros problème de cache. J'avais désactivé tous les systèmes de caches (j'utilise boost), dans le doute j'avais vidé manuellement tous les répertoires concernés, à savoir dans le dossier /cache et les répertoires /sites/theme/files/...

Je n'ai pas le souvenir d'avoir fait autre chose.

Bon courage, je sais que c'est la misère de perdre autant de temps sur ces pbs.

Yvan.

Après test, je pense que la version pour Drupal 7 se base sur les formats de text pour faire le lien avec les rôles.

Si un rôle n'a accès qu'au format Plain text, il ne pourra pas voir CKeditor.

L'affectation au niveau CKeditor ne se fait donc plus par rôle mais au niveau du format de texte.

alors j'ai supprimer le cache cela ne change rien

j'ai également vérifier tous les paramètres "format d’entrée" et droits d'accès dans ckeditor
j'ai du passer a coté de quelques chose!
au seccccccccccccccccourrrrrrrrrrrrrrrs!

Certains éditeurs, comme TinyMCE demandent l'activation des boutons présents dans leur barre d'outils.

Il faut aussi vérifier là hhttp://example.com/admin/people/permissions que les rôles ont les bons droits ("Utiliser le format de texte Full HTML").

Vérifier qu'il n'y a pas d'erreur Javascript sur la page, par exemple avec Firebug. Si un seul script plante, il peut très bien empêcher tous les autres de fonctionner.

Il peut être utile aussi de vider le cache du navigateur à l'occasion.

ok

apres une petite recherche avec firebug
j'ai une ligne d'erreur qui apparait lorsque je suis loggé sous un autre profil qu'admin
Drupal is not defined
[Stopper sur une erreur] var CKEDITOR_BASEPATH = Drupal.settings.ckeditor.editor_path;
je pense que ca vient de la effectivement
mais je sais pas quoi faire?

On ne contourne pas un problème d'erreur javascript de ce calibre : on le résout. Sinon rien ne fonctionnera normalement.

Est-ce que le tableau de bord du site indique des problèmes avec le filesystem ou autre chose ?

Est-ce que l'onglet 'réseau' de Firebug montre des lignes rouges, comme quoi il ne parvient pas à charger Drupal.js par exemple ? Ou un autre fichier de script ?

Il faudrait faire des tests en désactivant les autres modules chargeant du javascript.

je n'ai aucune ligne rouges dans l'onglet réseau
seulement un pb sur le fichier ckeditor.utils.js ligne 5
Drupal is not defined
[Stopper sur une erreur] var CKEDITOR_BASEPATH = Drupal.settings.ckeditor.editor_path;

rien d'anormal coté tableau de bord drupal