probleme installation Drupal 8 avec Composer

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,
J'ai fait mon site avec les version successives de Drupal depuis la 5 sur et là je suis passé à Drupal 8 toujours installé "à la main".
Ayant besoin de faire une mini boutique en ligne, je veux installer Drupal commerce qui demande le module Currency:
Mais ce module a besoin d'un bibliothèque qui ne peut s'installer que par Composer.
Après beaucoup de sueur pour remettre au Terminal et installer composer (qui en plus était déjà installé sur mon site mais je ne le savais pas !)
(et aussi beaucoup d'échec pour arriver à transformer mon site manuel en site sous composer )
Je décide de faire une faire une nouvelle installation du départ de Drupal 8:
mais là encore l'échec:
"Your requirements could not be resolved to an installable set of packages"
Il y a quelques discussions en anglais mais je ne comprends même pas s'il y a une solution
Comment la version officielle en ligne peut ne pas marcher ?

AU SECOURS JE CRAQUE !

Version de Drupal : 
Tags :