Mise à jour effectuée mais non détectée par Drupal

Bonjour,

Un petit coup de composer update drupal/core --with-dependencies donne "Nothing to install or update".

Quand je vais voir les "Mises à jour disponibles", ça donne :
"Drupal core 8.6.1 Mise à jour de sécurité nécessaire !

Version recommandée : 8.6.7 (2019-Jan-17) "

J'ai même essayé de forcer la 8.6.7 dans composer.json mais même résultat.

"require": {
"composer/installers": "^1.0.24",
"wikimedia/composer-merge-plugin": "^1.4",
"drupal/core": "^8.6.7"
},
"replace": {
"drupal/core": "^8.6.7"
},

Une idée à me soumettre ?

Version de Drupal : 
Tags : 

Salut Cinephil ça gaze ? ;-)
Le plus simple pour mettre à jour le core de Drupal 8 via Composer (et en plus ça mettra à jour les modules en même temps si besoin) c'est d'écrire ces 2 lignes :
composer clear-cache (juste au cas où)
puis
composer update

Bonne journée
Paps

Bonjour Gilles,
Visiblement dans la console Linux, ça a chargé un tas de trucs mais c'est toujours pareil ; Drupal me dit qu'il est en 8.6.1. :(

Une autre idée à me soumettre ?

Phil

Philippe Leménager
Ingénieur d'étude en informatique à l'ENSFEA, Toulouse.
Autoentrepreneur informaticien en activité complémentaire.
Modérateur de forums sur Developpez.com

Tu peux essayer plusieurs choses :
1. composer update drupal/core symfony/config --with-dependencies
ou
2. composer update drupal/core webflo/drupal-core-require-dev --with-dependencies

Sinon en dernier recours

Supprimer le dossier core & vendor
sudo composer install
sudo composer update
Vider cache navigateur ou attendre qqles heures
Dans le fichier settings.php -> ligne 325 : $settings['update_free_access'] = FALSE; passer à "TRUE"
puis
faire "nomdusite.com/update.php"
remettre à FALSE

Voilà tout ce que je peux te dire
Bonne chance
Paps

Bonjour à tous
J'ai aussi le même soucis avec composer
J'ai bien suivi ta procédure :

composer clear-cache
composer update

composer update drupal/core symfony/config --with-dependencies
composer update drupal/core webflo/drupal-core-require-dev --with-dependencies

puis

Supprimer le dossier core & vendor
composer install
composer update
Vider cache navigateur
Dans le fichier settings.php -> ligne 325 : $settings['update_free_access'] = FALSE; passer à "TRUE"
puis
faire "nomdusite.com/update.php"
remettre à FALSE

Enfin j'ai terminé par
composer clear-cache
composer require drupal/core --update-with-dependencies

Et voici le message :

Nothing to install or update
Generating autoload files
Class Drupal\Core\Composer\Composer is not autoloadable, can not call pre-autoload-dump script
Class Drupal\Core\Composer\Composer is not autoloadable, can not call post-autoload-dump script

Mon drupal est toujours en 8.5.1

Mon composer.json :

"require": {
"composer/installers": "^1.0.24",
"wikimedia/composer-merge-plugin": "^1.4",
"monolog/monolog": "^1.24",
"drush/drush": "^9",
"phpdocumentor/reflection-docblock": "^2.0",
"drupal/core": "^8.6"
},
"replace": {
"drupal/core": "^8.6.10"
},

un grand merci pour votre aide

Bonjour à tous,

Je suis dans la même problématique. Les procédures proposées (drush et composer) par drupal ne fonctionne pas.

Debian 9
Drush : 9.5.2
Composer: 1.8.0
Php 7.3.1.1

Et voici comment j'ai réussi à faire la mise à jour, sachant que j'avais des paquets (je ne suis pas sur du nom) supplémentaires dans le composer.json :

Pour une meilleure gestion des fichiers je conseil d'utiliser Git
Récupérer la dernier version du core.
Sauvegarder le composer.json de votre site et récupérer les lignes spécifiques utile : ("require": { xxxxx })
Copier le nouveau core drupal dans le projet (voir procédure de drupal )
Faire un composer require de chacun des paquets qui se situe dans l'ancien composer
Ex : composer require drush/drush
Pour les modules, vous avez la possibilité de les mettre à jour grâce à composer ou manuellement, composer va se charger de mettre à jour vos modules, attention ceux-ci doivent être impérativement dans le dossier /modules/contrib/
La commande composer fonctionne pour la mise à jour des modules.

J'espère que cela pourra vous aider.

Bonne journée

Yano

Probesys.com

merci pour ta réponse

Malheureusement ça ne marche toujours pas et comprends les messages de composer

composer require drupal/core --update-with-dependencies

Do not run Composer as root/super user! See https://getcomposer.org/root for details
Using version ^8.6 for drupal/core
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Writing lock file
Generating autoload files
Class Drupal\Core\Composer\Composer is not autoloadable, can not call pre-autoload-dump script
Class Drupal\Core\Composer\Composer is not autoloadable, can not call post-autoload-dump script

Bon, finalement, la meilleure méthode fonctionnelle que j'ai trouvée est la suivante :

Télécharger la dernière version puis la décompresser.
Copier les répertoires core et vendor sur les existants. Ainsi, les éventuelles librairies additionnelles dans vendor ne seront pas détruites.
Un coup de update.php.
Revenir au site et mettre à jour les modules via le site.

Bien sûr tout ça en ayant fait la sauvegarde du site et de la BDD avant.

Philippe Leménager
Ingénieur d'étude en informatique à l'ENSFEA, Toulouse.
Autoentrepreneur informaticien en activité complémentaire.
Modérateur de forums sur Developpez.com

Salut,

Effectivement il n'existe aucun module à ma connaissance qui réponde à ton problème.
Le mieux serait de soit trouver une présentation alternative sur ton site, ou développer un module en te baisant sur le module "disclaimer".