Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Drupal 8.5.3 : installation base de données lors de la première utilisation

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,

Je suis débutant dans la création de site web, même si j'ai de bonnes notions en informatique.
J'ai pris un hébergement chez OVH sur lequel j'ai créé, via l'interface proposée par OVH, une base de données MYSQL v.5.6.

J'ai uploadé à l'aide de filezilla, l'ensemble des fichiers de Drupal 8.5.3 (dézippés) dans un dossier nommé www.

Lorsque je me connecte à l'adresse de mon site, l'installation de drupal se lance www.xxxxx.fr/core/install.php.
Les étapes suivantes se déroulent bien : choisir une langue, choisir un profil, vérification des prérequis...

L'étape suivante me pose problème : installation de la base de données.
Je renseigne comme demandé le nom de la base de données, le type de base de données, le nom d'utilisateur de la base de données ainsi que le mot de passe. Tout ceci identique aux informations fournies par ovh lors de la création de la base de données via leur interface.

J'obtiens alors le message d'erreur suivant :
Échec de connexion à votre serveur de base de données. Le serveur retourne le message suivant : SQLSTATE[HY000] [2002] No such file or directory.

Info complémentaire : lorsque je jette un oeil à cette base de données via PHPMyadmin, je m'identifie et cela fonctionne mais la première page sous phpmyadmin m'indique : aucune tabla n'a été trouvée dans cette base de données.
Lorsque je crée cette base de données via l'interface ovh, le nom d'utilisateur et le nom de la base de données sont identiques, non différentiables.

Questions :
- une table est-elle obligatoire dans une base de données pour permettre son fonctionnement ?
- Avez-vous une idée quant à l'origine de mon problème ?

Je remercie ceux qui me répondront car j'ai cherché longtemps sans rien trouver de concluant...

Bonjour,

tu as indiqué :

comme demandé le nom de la base de données, le type de base de données, le nom d'utilisateur de la base de données ainsi que le mot de passe.

Il manque le nom (ou l'adresse) du serveur ...
(il utilise "localhost" par défaut, ce qui n'est évidemment pas le cas).

Salut,

Merci pour ta réponse. Oui c'est bien ça, il me demande :

  • nom de la base de données : écrit comme présenté sous ovh xxxx333
  • type de base de données : ici MySQL v.5.6 (pas d'autres choix)
  • le nom d'utilisateur de la base de données : ici xxxx333
  • le mot de passe : yyyyy

ovh indique également "adresse du serveur" et c'est ce à quoi tu fait référence xxxx333.mysql.db mais l'installation de Drupal ne le demande à aucun moment, excepté si je déroule le menu "options avancées" dans lequel il demande l'hote et le numéro de port".

Je renseigne ces infos avec mot pour mot les informations données par le gestionnaire de base de données d'ovh...
J'ai de toutes façons tenté de renseigner la case "nom de la base de données" par l'adresse du serveur et ça ne fonctionne pas.