Message d'avertissement

The subscription service is currently unavailable. Please try again later.

[Résolu] User warning: The following module is missing from the file system: swaps

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous !

Je rencontre un souci depuis un petit moment et je ne comprend vraiment pas la provenance de celui-ci.

Drupal m'affiche ce message d'erreur (dans le tableau de bord et dans update.php notamment)

User warning: The following module is missing from the file system: swaps in drupal_get_filename() (line 250 of core\includes\bootstrap.inc).

drupal_get_filename('module', 'swaps') (Line: 273)
drupal_get_path('module', 'swaps') (Line: 134)
module_load_include('install', 'swaps') (Line: 93)
module_load_install('swaps') (Line: 82)
drupal_load_updates() (Line: 109)
Drupal\system\SystemManager->listRequirements() (Line: 49)
Drupal\system\Controller\SystemInfoController->status()
call_user_func_array(Array, Array) (Line: 123)
Drupal\Core\EventSubscriber\EarlyRenderingControllerWrapperSubscriber->Drupal\Core\EventSubscriber{closure}() (Line: 574)
Drupal\Core\Render\Renderer->executeInRenderContext(Object, Object) (Line: 124)
Drupal\Core\EventSubscriber\EarlyRenderingControllerWrapperSubscriber->wrapControllerExecutionInRenderContext(Array, Array) (Line: 97)
Drupal\Core\EventSubscriber\EarlyRenderingControllerWrapperSubscriber->Drupal\Core\EventSubscriber{closure}()
call_user_func_array(Object, Array) (Line: 144)
Symfony\Component\HttpKernel\HttpKernel->handleRaw(Object, 1) (Line: 64)
Symfony\Component\HttpKernel\HttpKernel->handle(Object, 1, 1) (Line: 57)
Drupal\Core\StackMiddleware\Session->handle(Object, 1, 1) (Line: 47)
Drupal\Core\StackMiddleware\KernelPreHandle->handle(Object, 1, 1) (Line: 99)
Drupal\page_cache\StackMiddleware\PageCache->pass(Object, 1, 1) (Line: 78)
Drupal\page_cache\StackMiddleware\PageCache->handle(Object, 1, 1) (Line: 47)
Drupal\Core\StackMiddleware\ReverseProxyMiddleware->handle(Object, 1, 1) (Line: 38)
Drupal\webprofiler\StackMiddleware\WebprofilerMiddleware->handle(Object, 1, 1) (Line: 50)
Drupal\Core\StackMiddleware\NegotiationMiddleware->handle(Object, 1, 1) (Line: 23)
Stack\StackedHttpKernel->handle(Object, 1, 1) (Line: 656)
Drupal\Core\DrupalKernel->handle(Object) (Line: 19)

Jusque là ça ne me dérangeais pas trop. Cependant, ayant tenté un import de configuration de ma version locale vers ma version en ligne, voici que je reçois cette erreur :

La configuration ne peut être importée car la validation a échoué pour les raisons suivantes :

    La configuration swaps.settings dépend de l'extension swaps qui ne sera pas installée après l'importation.
    La configuration swaps.swapsettings_config dépend de l'extension swaps qui ne sera pas installée après l'importation.

J'ai recherché sur Drupal.org, sur Google, etc. je ne trouve aucune trace d'un module "swaps". Il semblerait qu'il y ait un rapport avec bootstrap, mais je ne comprend pas bien en quoi.

Est-ce que l'un d'entre-vous aurait une solution à ce problème ?

Merci d'avance !

Version de Drupal : 

Il semblerait que j'ai trouvé le moyen de me défaire de ces messages d'erreur en supprimant toutes les lignes mentionnant "swaps" dans la base de données.

D'après ce que j'ai pu voir, ça serait la mise à jour du core en 2.7.8 qui aurait provoqué ce bug, pour une raison que j'ignore totalement !

Si quelqu'un a plus d'explications...