Message d'avertissement

The subscription service is currently unavailable. Please try again later.

[Résolu] Refus d'enregistrer des modifications de contenu

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,
Je suis totalement néophyte. Je n'ai pas conçu le site pour lequel j'ai l'autorisation, comme administrateur, de créer, modifier du contenu, et d'autres possibilités que je n''exploite pas.
Depuis que j'ai effectué des mises à jour qui m'étaient conseillées, (je pense qu'avant j'avais la version 6.x) je me heurte à l'impossibilité de créer ou de modifier du contenu: lorsque je clique sur le bouton "enregistrer" j'ai le message suivant:

"PDOException : SQLSTATE[42S02]: Base table or view not found: 1146 Table 'db574882548.drupal_pathauto_state' doesn't exist: SELECT 1 AS expression FROM {pathauto_state} pathauto_state WHERE ( (entity_type = :db_condition_placeholder_0) AND (entity_id = :db_condition_placeholder_1) ); Array ( [:db_condition_placeholder_0] => node [:db_condition_placeholder_1] => 22 ) dans pathauto_entity_state_save() (ligne 492 dans /homepages/1/d574798486/htdocs/www/promemo.fr/sites/all/modules/pathauto/pathauto.module)."

Avec le commentaire suivant: "Le site Web a rencontré une erreur inattendue. Veuillez essayer de nouveau plus tard."

Je crois comprendre qu'il s'agit de lignes de code.

Je dois préciser que l'installation du site n'a pas eu lieu sur mon ordinateur, et que je réalise mes interventions sur le site à partir de sa page sur le web en ajoutant /user/login à l'URL du site, puis mon identifiant et mon mot de passe.

D'avance je vous remercie de vos explications B. Regaudiat

Version de Drupal : 

Est-ce qu'il s'agit d'une migration Drupal 6 / Drupal 7 ?

(j'ai effectué des mises à jour qui m'étaient conseillées, (je pense qu'avant j'avais la version 6.x) )

Si oui, je pense que la simple mise à jour n'est pas possible et risque de casser des choses

D'après le message, il manquerait une table dans la base de données. Il faut peut-être essayer de réinstaller le module pathauto, ou recréer la table manuellement ou à partir d'une sauvegarde

CREATE TABLE drupal_pathauto_state (
  entity_type varchar(32) NOT NULL COMMENT 'The entity type.',
  entity_id int(10) unsigned NOT NULL COMMENT 'The entity ID.',
  pathauto tinyint(4) NOT NULL DEFAULT '0' COMMENT 'The automatic alias status of the entity.',
  PRIMARY KEY (entity_type,entity_id)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COMMENT='The status of each entity alias (whether it was...';