Message d'avertissement

The subscription service is currently unavailable. Please try again later.

[Résolu] Doublon views URL cannonique / Url drupal

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

J'ai des doublons dans des views car ma views attrape l'URL canonique et l'URL Drupal.

CAD, j'ai dans la views :

Les contenus relatifs à http://monsite.fr/fr/ma-page-de-test ET Les contenus relatifs à ma http://monsite.fr/fr/node/64 .... Qui sont une seule et même URL ... Alors que je ne veux voir que http://monsite.fr/fr/ma-page-de-test ...

Merci d'éclairer ma lanterne. Les moyens classiques de dé-doublonnage (Count distinc) et autre ne marche pas ....

Merci la communauté ...

Salut Matthieu13,

Quelle version de Drupal utilises-tu ?

Tu fais une vue en allant chercher des contenus via leur URL ? Peux-tu expliquer la vue que tu veux faire (un screenshot de l'admin serait parfait) ?

-Floris

Merci pour ton aide Floris,

j'utilise D7.
non je fais des views en allant chercher des champs de contenus, mais j'ai des traductions, des URL classiques (Node/X) et des URL (propres) et j'ignore pourquoi pour une image et un titre et des liens (Facile) views me sort sur contenu pour node/12 et /ma-page-de-test ... Je cherche un moyen de le filtrer efficacement ... et je ne trouve rien. C'est la première fois que je coince pour un truc aussi basique ... Hallucinant ...

Merci pour ton aide.

Mais de rien... :)

Hum ... alors...

Dans Avancé > Autres , essaye de voir ce qui se passe lors que tu passes "utiliser l’agrégation" à OUI.
Je ne suis pas sûr de ça, mais c'est par là que mon esprit se dirige en premier lieu...