Message d'avertissement

The subscription service is currently unavailable. Please try again later.

[Résolu] Problème Update module

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

Depuis la fin de la semaine dernière il ne m'est plus possible de faire la mise à jour des modules de mes différents sites en passant par le BO avec Update Manager.
Sites hébergés chez OVH en mutu Pro, D7 version 7.50, 7.51 j'ai le message suivant :

L'erreur HTTP 0 s'est produite lors de la tentative de récupération de https://ftp.drupal.org/files/projects/webform-7.x-3.25.tar.gz.
Le téléchargement des mises à jour a échoué :

Echec du téléchargement de webform depuis https://ftp.drupal.org/files/projects/webform-7.x-3.25.tar.gz

En ftp c'est OK, avec drush c'est pas possible chez OVH en mutu.

Si vous avez une solution à ce problème je suis à l'écoute.
Merci.

Version de Drupal : 

Bonjour à tous,

Je rencontre le même problème (Drupal 7.50).
Je suis tombé sur un post en anglais dans lequel un utilisateur s'en était sorti en changeant sa version de PHP pour PHP 5.5.
Ça a fonctionné pour moi.

Salutations

Je viens d'avoir la réponse par la liste de diffusion d'OVH (web@ml.ovh.net) à laquelle je vous conseille de vous abonner.

Drupal a modifié la configuration du HTTPS sur ces serveurs récemment et cela impose l'utilisation de TLS1.2.
Vous êtes très probablement en environnement d'exécution "legacy" qui n'est pas compatible avec TLS1.2.
Vous pouvez migrer en environnement "stable", qui est compatible TLS1.2.
https://docs.ovh.com/fr/fr/web/hosting/modifier-lenvironnement-dexecutio...
Le coeur de drupal 7 n'a pas d'imcompatibilité avec l'environnement stable, cela devrait donc être transparent pour vous.

Merci

Le problème vient de la version de PHP

Ayant deux sites sur OVH, le problème concernant les mises à jour des modules ne se produisait que sur un seul site. En vérifiant la version de PHP utilisée sur le site qui ne pose pas de problème j'ai remarqué que la version de PHP était V5.4. J'ai donc modifié la version de PHP sur le site qui posait problème en passant de la V5.6 à la V5.4. Et surprise tout s'est déroulé normalement. L'ensemble des modules en attentes sont maintenant à jour. J'ai ensuite remis la version de PHP à V5.6 comme auparavant.
Problème résolu.

Je confirme, pour celles et ceux qui rencontrent ce type d'erreur, ne pas hésiter à changer de mode.
Pour ma part je suis passé en version "Stable" et en "PHP 7" et plus d'erreurs. Cependant, n'oubliez pas de faire un backup complet de votre site web ;-)