Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Pb installation Drupal 6.x en local : Windows XP et WampServer

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

Je n'arrive pas à installer Drupal 6.x sur mon PC Windows XP

Actions effectuées :

Installation WampServer Version 2.0 (tout par défaut puis reboot)
Du coup Version APACHE = 2.2.11
Du coup Version PHP = 5.2.8
Du coup Version MySQL = 5.1.30

Je crée une base de donnée : gite (tout par défaut)

Téléchargement de drupal-6.9.tar.gz ET fr-6.x-1.0.tar.gz pour la traduction française
Je mixe les 2 et place le tout dans c:\program file\wamp\www\drupal

je recopie et renomme C:\Program Files\wamp\www\drupal\sites\default\default.settings.php en settings.php

Je lance mon navigateur Firefox http://localhost/drupal

L'installation commence:
Les msgs d'erreur suivants sont d'entrée affichés :

Notice: Undefined index: locale in C:\Program Files\wamp\www\drupal\install.php on line 560

Notice: Undefined index: locale in C:\Program Files\wamp\www\drupal\install.php on line 560

Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in C:\Program Files\wamp\www\drupal\includes\locale.inc on line 2305

Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in C:\Program Files\wamp\www\drupal\includes\locale.inc on line 2340

Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in C:\Program Files\wamp\www\drupal\includes\locale.inc on line 2354

Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in C:\Program Files\wamp\www\drupal\includes\locale.inc on line 2421

Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in C:\Program Files\wamp\www\drupal\includes\locale.inc on line 2465

Je choisi french et décide de continuer !
CHOIX DE LA LANGUE D'INSTALLATION : Ok
VERIFICATION DES PRE-REQUIS : Ok
INSTALLATION DE LA BASE DE DONNEES : Ok (gite et root sans mot de passe par défaut)
A ce moment là : les tables dans ma base de données sont créées
Puis:

PLANTAGE LORS DE L'INSTALLATION DU SITE: MSG D'ERREURS :

* user warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY fit DESC LIMIT 0, 1' at line 1 query: SELECT * FROM menu_router WHERE path IN () ORDER BY fit DESC LIMIT 0, 1 in C:\Program Files\wamp\www\drupal\includes\menu.inc on line 315.
* user warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY fit DESC LIMIT 0, 1' at line 1 query: SELECT * FROM menu_router WHERE path IN () ORDER BY fit DESC LIMIT 0, 1 in C:\Program Files\wamp\www\drupal\includes\menu.inc on line 315.

Je craque !
Plusieurs fois même manip et pb idem !
Idem aussi avec Drupal 6.6 Drupal 6.8

Merci de m'aider svp.
J'aimerai bien arriver à exploiter ce CMS très vite

Version de Drupal : 

Bonjour,

J'ai le même problème visiblement :

WindowsXP édition familiale SP3
WampServer 2.0f

Version Apache: 2.2.11
Version PHP: 5.2.8
Version MySQL: 5.1.30

Ce que j'ai fait :
- décompresser drupal-6.9 dans le dossier www de wamp
- le renommer en drupal
- y coller le contenu du dossier fr-6.x-1.0 en le fusionnant
- copier le fichier drupal\sites\default\default.settings.php en settings.php
- lancer WampServer
- aller sur http://localhost/drupal

J'ai la page http://localhost/drupal/install.php?profile=default
"Choose language" avec :

Notice: Undefined index: locale in E:\wamp\www\drupal\install.php on line 560
Notice: Undefined index: locale in E:\wamp\www\drupal\install.php on line 560
Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in E:\wamp\www\drupal\includes\locale.inc on line 2305
Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in E:\wamp\www\drupal\includes\locale.inc on line 2340
Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in E:\wamp\www\drupal\includes\locale.inc on line 2354
Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in E:\wamp\www\drupal\includes\locale.inc on line 2421
Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in E:\wamp\www\drupal\includes\locale.inc on line 2465

C'est grave docteur?

Bonsoir,

Merci de tes infos tous5pas.
Et tu n'as plus de message d'erreur du tout? Même pas les erreurs de Notice?

Contrairement à toi, je n'ai pas ZoneAlarm, ni de pare-feu Windows, ni aucune trace de rien de bloqué dans Kaspersky (que j'ai même désactivé un coup pour voir, houlà!).

Je peux continuer l'install de Drupal apparemment sans problème et sans autre erreur, mais j'aimerais quand-même savoir quelle est la portée de ces erreurs de Notice, histoire d'être sûr d'avoir un truc propre au départ.

J'ai essayé avec EasyPHP, même résultat :

Notice: Undefined index: locale in E:\EasyPHP 3.0\www\drupal\install.php on line 560
Notice: Undefined index: locale in E:\EasyPHP 3.0\www\drupal\install.php on line 560
Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in E:\EasyPHP 3.0\www\drupal\includes\locale.inc on line 2305
Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in E:\EasyPHP 3.0\www\drupal\includes\locale.inc on line 2340
Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in E:\EasyPHP 3.0\www\drupal\includes\locale.inc on line 2354
Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in E:\EasyPHP 3.0\www\drupal\includes\locale.inc on line 2421
Notice: Use of undefined constant LANGUAGE_RTL - assumed 'LANGUAGE_RTL' in E:\EasyPHP 3.0\www\drupal\includes\locale.inc on line 2465

C'est grave docteur?
D'autres ont ce truc là aussi???
Question idiote????
Y'a quelqu'un?????

coopérativement
Brn

OK, OK, je me réponds : question idiote... problème de LANGAGE_RTL (right to left) autrement dit probablement parce que mon Windows chéri ne reconnaît pas les langages qui s'écrivent de droite à gauche.
Donc pas grave du tout.
D'ailleurs, aucun souci par la suite dans mes essais en local, lesquels se poursuivent tranquillement.

N'empêche, z'auriez pu me le dire ceux qui savaient que c'était une question idiote, j'avais tendu la perche! ;-)

amicalement
Brn