Message d'avertissement

The subscription service is currently unavailable. Please try again later.

problème aprés l'installation

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

J'ai ce message d'erreur qui apparait dés que je me connecte sur le site mais je ne trouve pas le blème...

Help Me

Kreatifs

warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File() is not within the allowed path(s): (/home/httpd/vhosts/kit-solaire.ch/httpdocs:/tmp) in /home/httpd/vhosts/kit-solaire.ch/httpdocs/includes/file.inc on line 756.
Le fichier n'a pas pu être créé.
warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File() is not within the allowed path(s): (/home/httpd/vhosts/kit-solaire.ch/httpdocs:/tmp) in /home/httpd/vhosts/kit-solaire.ch/httpdocs/includes/file.inc on line 756.
Le fichier n'a pas pu être créé.

Version de Drupal : 

Que dire de plus que j'ai installé la version 6 de drupal et j'ai ce problème qui me vient sur l'écran dés que je me connecte sur le site en entrant un mdp et un login, le message me parle d'un problème à la ligne du fichier "file.inc" du du répertoire/includes/file.inc
Je sais pas si il faut modifier le texte sur le fichier file.inc

a moins que quelqu'un n'ai une meilleure idée, mais pour moi, c'est un problème a voir avec ton FAI... rien a voir avec Drupal.

Sinon tu crée ton propre répertoire tmp, et tu fais pointer drupal dessus, comme ca, plus de pb.

exactement le même problème avec un serveur mutualisé chez haisoft.
je n'ai pas encore la solution non plus.

après un court débug à l'arrache, il semblerait que ce soit realpath(file_directory_temp()) qui renvoie une chaine vide

finalement, en créant un répertoire sites/default/files/tmp en php (pour avoir le bon propriétaire), ça semble mieux marcher. De mon côté, j'ai le safe_mode ON, ce qui semble paniquer un peu l'engin. Donc je ne sais pas si ça marche, mais en tout cas, le message d'erreur a changé.

on me désactive le safe mode dans la journée, je vous tiens au courant.

en fait, le message d'erreur ne m'empêchait pas d'aller installer le module devel. donc je l'ai installé et j'ai activé le bloc pour executer du php.
dans la boite de php,
realpath('sites/default/files')
te donne le path pour faire un mkdir() propre pour le répertoire sites/default/files/tmp
Par ton ftp (ou ton panel qui permet de voir ça), tu vas voir que le propriétaire de ce nouveau répertoire est apache.
Une fois ça fait, tu actualises ta page, et normalement, ça marche.
En tout cas, chez moi, ça a marché (un peu miraculeusement, je l'avoue).

La vérif que tu peux faire, c'est taper
print(realpath(file_directory_temp()));
là, il n'est plus sensé te sortir une chaine vide. Ce qui était certainement le cas avant la manip.

ça marche chez toi ?

tu installes le module devel dans sites/all/modules (il faut en général avoir créé le répertoire modules qui n'y est pas par défaut)
ensuite tu l'actives en allant dans
administrer > modules
tu coches "devel", tu enregistres (bas de la page)
tu passes dans
administrer > blocs
tu glisses le bloc "executer php" dans le pied de page par exemple,
tu enregistres.
le tour est joué.

Ahah encore juste une question toi qui te débrouille pas mal

mon fichier drupal est dans le httpdocs du serveur sous
httpdocs/drupal

ce qui fait que quand quelqu'un tape www.yoursiteweb.net il arrive pas sur mon site mais une page du serveur apache tu connais un petit php de redirection que je peux installé directement dans le httpdocs qui va envoyer le visiteur sous www.yoursiteweb.net/drupal ?
Merci d'avance

Je ne maitrise pas trop, mais peut-être qu'en rajoutant un alias dans le httpdocs/.htaccess ça peut passer.
Je ne sais pas exactement.
par contre, dans ce cas, je ne sais pas si ce n'est pas plus simple de relancer l'install parce que ça doit modifier ton settings.php et certainement d'autres choses.
Je ne suis définitivement pas assez calé pour répondre ;)