Message d'avertissement

The subscription service is currently unavailable. Please try again later.

problème d'installation D8 RC1 sur OVH mutualisé

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour

J'ai voulu tester Drupal 8 RC1 en l'installant sur mon hébergement OVH mutualisé, et ça ne s'est pas bien passé. L'installation bloque à l'étape de l'installation de la base de donnée.
Je me retrouve avec le message d'erreur suivant :

Warning: Zend OPcache API is restricted by "restrict_api" configuration directive in system_requirements() (line 246 of core/modules/system/system.install).

system_requirements('install')
drupal_check_profile('standard', Array)
install_check_requirements(Array)
install_verify_requirements(Array)
install_run_task(Array, Array)
install_run_tasks(Array)
install_drupal(Object)

Resolve all issues below to continue the installation. For help configuring your database server, see the installation handbook, or contact your hosting provider.
Your MySQL server and PHP MySQL driver must support utf8mb4 character encoding. Make sure to use a database system that supports this (such as MySQL/MariaDB/Percona 5.5.3 and up), and that the utf8mb4 character set is compiled in. See the MySQL documentation for more information.
The libmysqlclient driver version 5.1.73 is less than the minimum required version. Upgrade to libmysqlclient version 5.5.3 or up, or alternatively switch mysql drivers to MySQLnd version 5.0.9 or up.

J'ai fait une demande d'assistance aurpès d'OVH, ils m'ont données les versions utilsés sur mon hébergement :
- mysql 5.5.4 donc supérieur au minimum requis (qui est le même que D7 et D7 fonctionne sans soucis)
- PHP 5.4 au minimum = dans ovhconfig, j'ai mis app.engine.version=5.6 donc supérieur à la 5.5.9 requise
- pour la version de libmysqlclient : pas de réponse d'OVH.

J'ai testé avec des version dev, bêta.... toujours le même soucis.

En cherchant sur google, j'ai vu plusieurs utilisateur ayant ce problème sur des serveurs mutualisé dont OVH.
J'ai fait suivre mon problème sur ce sujet : https://www.drupal.org/node/2568351#comment-10452933
en espérant que les choses s'améliorent.

Du coup, je me demandais si quelqu'un avait déjà installer D8 sur ovh et si il avait rencontré ces difficultés ?

Version de Drupal : 

Bonjour Edel, et bravo d'essayer d'installer drupal 8 sur OVH.

Je suis en mutualisé avec je pense une offre gold.
Je n'ai pas eu de problème pour installer D8 jusqu'à la version beta9 (premier trimestre 2015).

Après drupal a durci ses "prérequis".
Il faut maintenant un jeu de caractères utf8mb4 (plus moderne) et non plus seulement utf8.
Quand on entre dans ovh / manager / ancienne interface client / hébergement / PhpMyAdmin / … Onglet Bases de données / paramètres généraux / interclassement pour la connexion au serveur / combo box . Si on ne voit pas dans les valeurs possibles : utf8mb4_unicode_ci, c’est que la version du serveur qui s’est installé lors de la création de la première table est trop ancienne.
Avec une offre gold, on a droit que a une seule base de données.et encore elle est mutualisée donc OVH ne la modifie pas.

Alors on peut faire comme OVH me l’a conseillé : sauvegarder sa base, l’effacer ou la supprimer, la recréer sur un autre serveur plus récent, et recharger sa sauvegarde. Je ne pense pas que cela soit suffisant.

Réponse OVH :
D'après la documentation officiel MySQL je constate que l'UTF8MB4 n'est valable qu'à partir de base de données en version 5.5.3 Or mysql5-18.perso, et mysql51-93.perso sont en version 5.1, version que vous avez choisi lors de leur création.
Je vous invite ici à sauvegarder vos bases, à les vider, à les supprimer puis à les recréer en 5.5 avant de réimporter vos données ce qui devraient vous permettre d'utiliser l'UTF8MB4.

Il s’agit de la version de la base de données et pas de la version PHP.

Moi, j’ai préféré reprendre un nouvel hébergement, et là j’ai bien : utf8mb4_unicode_ci.
Seulement j’ai toujours le même message

La première partie doit n’être qu’un warning pas grave :

---Warning: Zend OPcache API is restricted by "restrict_api" configuration directive in system_requirements() (line 246 of core/modules/system/system.install).
• system_requirements('install')
• drupal_check_profile('standard', Array)
• install_check_requirements(Array)
• install_verify_requirements(Array)
• install_run_task(Array, Array)
• install_run_tasks(Array)
• install_drupal(Object)

la suite est plus sérieuse
--- Resolve all issues below to continue the installation. For help configuring your database server, see the installation handbook, or contact your hosting provider.
o Your MySQL server and PHP MySQL driver must support utf8mb4 character encoding. Make sure to use a database system that supports this (such as MySQL/MariaDB/Percona 5.5.3 and up), and that the utf8mb4 character set is compiled in. See the MySQL documentation for more information.

Ce problème doit maintenant être réglé pour moi, je pense, le reste me semble plus difficile

o The libmysqlclient driver version 5.1.73 is less than the minimum required version. Upgrade to libmysqlclient version 5.5.3 or up, or alternatively switch mysql drivers to MySQLnd version 5.0.9 or up.

Quand je lis cela, je crois comprendre qu’il manque une librairie ou qu’un driver n’est pas à niveau, ou quelque chose comme cela, mais je ne suis pas expert.

La réponse à ma demande de OVH :
Au niveau de l'installation de Drupal sur votre base de données. Cela ne sera pas possible pour le moment, les bases SQL mutualisés ne contenant (pour le moment) le charset nécessaire qui sera mis à jour en 2016.
Afin de transcender cette limitation vous pouvez néanmoins :
* Installer Drupal en local
* Exporter la base de données et changez le charset avant de l'importer dans la base OVH

Peut-être ? mais cela me semble assez compliqué pour les drupaliens non-experts, et est-ce que cela résout tous les problèmes ?
Peut-être que d’autres gentils drupaliens pourraient faire pression sur OVH pour qu’il mette ses bases de données à jour (on paye). C’est ce que j’espère.

Ou que l’on demande à drupal de revenir sur ses nouveaux prérequis, Cela doit être tout à fait saugrenu. Mais le nombre de caractères vraiment utilisés quand on passe de utf8 à utf8mb4 ne doit pas être très important, drupal doit pouvoir faire un transcodage, mais c’est vrai, cela n’est pas très propre et ferme la porte à de nouvelles améliorations.

Voilà, j’espère que le temps passé à commenter, ne sera pas perdu pour nous, que d’autres personnes avec d’autres infos ou plus expérimentées pourront m’aider ou nous aider, en voulant bien commenter la demande. Normalement OVH devrait sans attendre mettre à jour ses bases de données. Peut-être qu’en insistant un peu, si on est nombreux, on pourra y arriver.

Beve91

Charset utf8mb4

Dans .\drupal-8.0.0-rc1\core\lib\Drupal\Core\Database\Driver\mysql\Connection.php
Il y a le code suivant

    if (isset($connection_options['_dsn_utf8_fallback']) && $connection_options['_dsn_utf8_fallback'] === TRUE) {
      // Only used during the installer version check, as a fallback from utf8mb4.
      $charset = 'utf8';
    }
    else {
      $charset = 'utf8mb4';
    }

En forcant à 'utf8' $charset dans le"else" ca passe = remplacer le code précédent par :


      $charset = 'utf8';

"utf8mb4" est aussi utilisé dans :
.\drupal-8.0.0-rc1\core\lib\Drupal\Core\Database\Driver\mysql\Schema.php

    $table += array(
      'mysql_engine' => 'InnoDB',
      'mysql_character_set' => 'utf8',
//      'mysql_character_set' => 'utf8mb4',
    );

Je pense qu'en mettant


  array(
    'driver' => 'mysql',
    'database' =>
...
   'collation' => 'utf8_general_ci',
  );

Cela permet de se passer du charset utf8mb4

The libmysqlclient driver version 5.1.73

J'ai forcé la version minimum dans ..\drupal-8.0.0-rc1\core\lib\Drupal\Core\Database\Driver\mysql\Install\Tasks.php


  const LIBMYSQLCLIENT_MINIMUM_VERSION = '5.1';
// const LIBMYSQLCLIENT_MINIMUM_VERSION = '5.5.3';

Mais .... en débloquant ces controles, je n'ai pas un comportement "normal" de mon installation.
Le thème
Je me pose maintenant les questions suivantes :
- Ces controle bloquant sont-ils necessaires ? Pourquoi en beta10 n'était-il pas présent ?
- En les débloquant, est-ce que le site va-il bien fonctionner ?

Après l'installation, tous semble conforme....

Salut
J'ai un peu testé ça aujourd'hui, donc on arrive à "installer" D8 en modifiant ces paramètres. Par contre, j'ai eu des bugs : je ne peux pas installer de module et je ne peux pas changer de thème.
C'est bien dommage, car du peu que j'ai pu voir la version 8 a l'air très sympa.

Voici la réponse d'OVH pour la fonction OPCache :
" Zend optimizer n'existe plus sur phpfpm, c'est zendopcache qui est maintenant
actif par défaut.
Puisque vous êtes sur une nouvelle offre :

  • désactiver le .ovhconfig avec les lignes :

app.engine=phpcgi
app.engine.version=AUTO

  • commandes standards dans le .htaccess
    Guide pour le .htaccess :
    guide.ovh.com/ConfigPhp
    "
    J'ai testé, mais ça ne marche pas.

Je me demande à partir de quelle formule d'hébergement D8 fonctionne chez OVH.

Je pense que pour gérer un site Drupal, le mieux est d'avoir un VPS.

Je viens d'installer un Drupal 8 en quelques minutes sur un VPS SSD1 : (http://d8.hebinweb.com).

Si ça vous intéresse, j'ai des formules d'hébergement technique quasiment au même prix qu'un hébergement mutualisé OVH, mais avec du PHP 5.6 + OpCache activé, et des limites plus élevées de mémoire, du cache memcache, un serveur nginx etc.

Merci pour ton retour.
Je ne m'en sors pas non plus avec l'assistance OVH, certainement parce que je n'ai qu'un mutualisé de base...
Sur le forum anglais, j'ai vu que certains utilisateurs avaient ces soucis sur des serveurs mutualisés, pas qu'OVH.
Du coup, je ne sais pas si je continue mon site sur D8 ou si je reviens sur D7, voir quitter drupal et essayer autre chose.
Demain, j'essayerai tes modif' pour voir, merci en tout cas.

Bonjour à tous,

L'assistance OVH, premier niveau a pour tache de nous envoyer paitre rapidement avec des solutions ubuesques du genre :
« Votre demande ne rentre pas dans le cadre de notre support puisqu'il s'agit du développement de votre site internet et la gestion de votre base SQL. Je vous invite donc pour cela à vous documenter sur internet ou à passer par un webmaster. »
En fait il faut insister un peu pour qu'un technicien compétent réponde.

Si quelqu’un peut faire un résumé des dernières réflexions de Drupal pour ceux qui ne comprennent pas tout , avec ces billets, et d’autres:
https://www.drupal.org/node/2521784
https://www.drupal.org/node/1314214?page=1
https://www.drupal.org/node/2529188
https://www.drupal.org/node/2533424

Quels sont les conseils que l'on peut donner.

Merci

beve91

drupal8 sur OVH mutualisé perso2014

Bonjour,

ce que je retiens de mon expérience personnelle OVH-Mutu-perso2014 et de mes entretiens avec le support, c'est qu'il faudra patienter jusqu'à la mise à jour de libmysqlclient.
Elle serait à espérer dans les tous prochains mois.
Mon expérience : installation D8 qui coince chez OVH sur l'offre perso2014 - PHP 5.6.6 ok et MySQL 5.5.44 ok mais PHP-libmysqlclient 5.1.73 KO)
Réponse donnée à mon problème : je cite "Suite au retour du support concerné [ma question avait été escaladée] je tiens à vous informer qu'il y a une mise à jour déja prévu par rapport au driver libmysqlclient mais qui prendra du temps.
Par ailleurs, on n'a pas de délais précis.
"

Pourquoi c'est si long ? surement qu'il ne suffit pas de claquer des doigts.

S'il fallait risquer un conseil, ou des pistes :
- patience... comme déjà pressenti il y a environ deux mois dans ce commentaire en anglais.
https://www.drupal.org/node/1314214?page=1#comment-10320325
- ou peut-être OVH-VPS ? http://drupalfr.org/comment/73669#comment-73669
- ou un autre hébergement ?