[Résolu] Affichage en mode "texte" des thèmes installés

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

Je viens de faire une installation de Drupal 7.37 "from scratch".

Tout a bien fonctionné mais quand je veux installer un nouveau thème à partir de la page d'administration, l'installation semble se dérouler correctement: il apparaît bien dans la liste et ses fichiers sont installés dans .../Drupal/sites/all/themes/nomdutheme.

Ce qui ne va pas, c'est que l'image corresponsant au thème n'apparaît pas dans la liste et que l'affichage des pages du site s'affiche en "mode texte".

Voici ce que ça donne :

Thème dans la listePage utilisant le thème

Ceci se produit avec tous les thèmes que j'ai essayé et notamment les plus téléchargés.

Quelqu'un pourrait m'aider? Je débute en Drupal.

Merci d'avance

Version de Drupal : 

Bonjour snulkit !

1 - Essai de vider les caches

2 - Vérifie que ton fichier "nom_de_ton_theme.info" se nomme bien comme le répertoire dans lequel il est situé.

3 - Vérifie que les fichier CSS sont bien là et qu'ils sont bien renseignés dans le fichier ".info".

4 - Vérifie peut-être que ce n'est pas un problème de configuration de la racine du site ou quelque chose comme ça. Par exemple si Drupal croit que la racine du site est "http:/localhost/" alors que c'est "http:/localhost/drupal" cela peut il me semble causer ce genre de problèmes. Pour régler ça édite le fichier "settings.php" ou le ".htaccess".

Bon courage !

Bonjour Besky,

Merci pour ta réponse.

les points 1 2 et 3 de ta réponse ont bien été vérifiés et tout était correct.

Pour le point 4, je site était bien installé dans le sous-répertoire Drupal.

Comme je n'ai pas trouvé où faire la modif dans "settings.php" et ".htaccess", j'ai supprimé l'installation de Drupal et l'ai réinstallé à partir de zéro directement dans la racine, puis réinstallé le thème en question.

Malheureusement, le résultat est toujours le même.

Je patauge et j'ai l'impression d'être le seul à avoir ce problème car je ne trouve rien à ce propos en cherchant sur Google :(

Ah oui, pour info, mon site est sur un serveur dédié (VPS) chez OVH qui tourne sous Gentoo release 2

J'ai résolu le problème :
Les permissions sur les répertoires sous /sites/all étaient mises à 744 et celles sur les fichiers à 644. J'ai modifié les permissions des répertoires vers 755 et tout fonctionne maintenant :-)
Par contre, je ne m'explique pas pourquoi l'installation de Drupal n'a pas mis les permissions correctes sur les répertoires automatiquement.