Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Search/indexation ne fonctionne pas

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

bonjour,
bien que search soit installé, l'indexation de mon site ne fonctionne pas (je ne sais pas si elle a déjà fonctionné).
Les tables search_* sont vides.
Que faut-il faire pour rétablir tout ça à votre avis?
Déjà l'activation de cron.php produit une page blanche, ça ne me semble pas trop normal? (pourtant je n'ai pas de log d'erreur).
Je suis en hébergement mutualisé.
Merci par avance

Version de Drupal : 

Toujours bloqué:
- aucune erreur dans les logs
- le module d'administration m'indique "traitement réglier cron réussi" (suite à "Vous pouvez lancer le cron manuellement")
... et pourtant les tables search_* restent vides!
Je ne sais pas trop quoi faire donc!

[Résolu]
Je pense qu'on peut clore:
pour une raison que je ne m'explique pas dans les logs ne figurait pas clairement l'appel à la fonction 'prg-replace' dépréciée dans le module 'search' (à remplacer par 'preg-replace-callback'), la version de php de l'hébergeur ayant dû évoluer.
Je n'ai vu ça que dans les rapports Drupal (au milieu de pas mal d'erreurs) dans l'admin.
Maintenant l'indexation est ok, et la recherche ça va beaucoup mieux!