Message d'avertissement

The subscription service is currently unavailable. Please try again later.

i18n sur Drupal 6 [RESOLU]

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,
ma question va vous sembler stupide, mais bon, je me lance :

comment faire apparaitre le bloc concernant le sélecteur de langues ?

à l'époque, j'avais déjà utilisé ce module avec drupal (v4.7 et 5.1 je crois) et je n'avais pas rencontré ce problème.

modules activés =
-Language Icons
-Multilingual Menu
-Mutilingual Blocks
-Strings

dans la partie /admin/build/block, le bloc "Sélecteur de langue" est placé dans le sidebar (j'ai varié les positions, mais ça n'a rien changé). de plus, j'ai le même résultat en utilisant différents thèmes.

de plus, je suis allé vérifier dans la partie /admin/user/permissions s'il y avait quelquechose à activer. j'ai même tenter en donnant la permission à tout utilisateur de "administer all languages"... rien de nouveau

en tout, dans la partie /admin/settings/language, j'ai 4 langues (en / fr / de / it)

merci d'avance pour vos lumières

Version de Drupal : 

pour y remedier,
j'ai seulement réinstallé le module (3fois en tout),
à un moment, ça a fonctionné.

pour le moment, j'ai donc le fameux bloc de selection de langue qui est apparu, avec les petits drapeaux,

mais je n'arrive pas à le fare fonctionner correctement :
je créai 3 contenu :
- biographie, à laquelle j'assigne la langue "française"
- biografia, ........................... "italienne"
- biography ................................. "anglaise"

à chacun, j'ai personnalisé son url
mais, le souci, c'est que le contenu ne varie pas en fonction de la langue sélectionnée.

vos idées sont les bienvenues, en attendant, j'essaye d'y remedier.

voila la solution :
dans /admin/settings/i18n
il faut selecitonner la ligne :
All content. No language conditions apply

de plus, je me suis passé des liens primaires et j'ai crée un menu par langue.
je ne sais pas si ça a changé qqchose