[Résolu]Problème de Mail

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

je ré-ouvre ce sujet car dans mon post précédent plusieurs paramètres interféraient;

depuis quelques jours (depuis la mise à jour de drupal 6.28 à 6.29 il me semble, mais sans certitude), le mail du site ne fonctionnait plus;

j'ai installé php mailer (et mime mail) et paramétré avec les données de OVH (hébergement mutualisé);

malgré tout ça ne fonctionne pas correctement; part exemple j'utilisais mail2all pour des envois groupés, ça ne fonctionne plus; les déclencheurs "envoyer un courriel" n'ont plus l'air de fonctionner;

ne fonctionne que la fonction mail directe et drupal_mail ne fonctionne plus, uniquement php mailer;

je suis un peu (beaucoup) perdu...

comment trouver ce qui ne va pas et où réparer les erreurs puisque je n'ai pas d'autres infos; le tableau de bord d'admin étant ok, excepté cette info que je n'arrive pas à corriger (autre topic ouvert ):
Temporary files directory Not fully protected
See http://drupal.org/SA-CORE-2013-003 for information about the recommended .htaccess file which should be added to the c:\windows\temp directory to help protect against arbitrary code execution.

merci de m'aider à trouver la bonne solution

Bonjour misterloup,

As tu regardé dans Rapports > Entrées récentes du journal (admin/reports/dblog) pour vérifier qu'aucun message d'erreur ne s'affiche ?

Sinon vérifie que tes modules sont bien à jour, que OVH ne t'a pas bloqué quelque part et que ton email est correctement configuré dans Drupal.

Essai aussi sur plusieurs emails au cas ou.

Sans plus d'informations j'ai bien peut de ne pas pouvoir faire plus pour toi pour le moment.

Bon courage !
Besky.

bonjour
j'ai réussi à régler le problème de fichiers temporaires; peut-être que cela participait au blocage; d'autre part j'ai arrêté les tests de mailing (350 inscrits au site) il semblerait qu'en hébergement mutualisé ça passe mal;
avec php mailer, il y a une fonction "debug" que j'ai activé qui m'aide à repérer les erreurs;
pour l'instant ça a l'air de refonctionner
merci