ckeditor et wysiwyg : pb d'installation (Résolu)

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

Je sais que le problème est souvent évoqué. J'ai écouté les tutos vidéo attentivement. Mais je coince sur l'installation de Ckeditor.
Avant d'y passer trop de temps je voudrais savoir si ça peut venir d'une mauvaise combinaison des versions où s'il y a une ruse de sioux qui m'échappe.

La démarche (je teste en local sous drupal 7.17):

  • j'ai téléchargé le module wysiwig (7.x-2.2) , décompressé l'archive et logé le répertoire dans sites/all/module/
  • j'ai activé le module
  • récupération sur ckeditor.com de la dernière version de ckeditor (4.0) , décompression de l'archive, répertoire /ckeditor/ logé dans sites>all>libraries
  • retour dans configuration>wysiwig profiles , là j'ai le message "The version of CKEditor could not be detected." puis une invitation à télécharger ckeditor

j'ai vérifié que le fichier ckeditor.js est bien présent dans libraries/ckeditor/ et c'est le cas.

J'ai vidé le cache du navigateur et repris la manip, même chose
J'ai désactivé puis désinstallé wysiwyg et refait l'instal avec la dernière version dev de wysiwyg, mais c'est pareil.

Bref : je coince.

Version de Drupal : 

Bonjour,

je ne sais pas si Wysiwyg est compatible avec la dernière version de CKEditor (4.0).

Généralement, je télécharge les librairies (http://download.cksource.com/CKEditor/CKEditor/CKEditor%203.6.5/ckeditor...) dans sites/all/libraries.

J'ai donc le JS correspondant : sites/all/libraries/ckeditor/ckeditor.js

Le module est vu par wysiwyg.

Donc j'essaierai avec la version 3.6.x, pour vérifier si cela fonctionne.

Je viens de faire l'essai avec :

  • la version 3.6.4 de ckeditor
  • module wysiwyg 7.x-2.2
  • module drupal ckeditor 7.x-1.11

Et ça marche.
(penser à activer les boutons ->
admin>configuration>rédaction de contenu>wysiwyg profiles> action : "modifier" ckeditor
dans "buttons et plugins" il faut cocher les boutons qu'on souhaite faire apparaitre.

Merci pour ta réponse. En espérant que ces précisions fassent gagner du temps aux autres.

Bonjour,
Sous drupal 7.18 j'ai effectué la mise à jour du module ckeditor-7.x-1.11 en laissant la version 3.6.2 présente (dans le module et pas dans les libraries).
Ça fonctionnait très bien avec ckeditor-7.x-1.9 sans wysiwyg (qui n'est pas compatible avec le module).
L'éditeur a disparu en ayant fait l'update, vidé les caches…
J'ai chargé la version 4.0 et je me suis rendu compte là que la mise à jour m'avait supprimé le bon chemin. De plus les skins et plugins ne sont pas intégrés, donc les boutons traditionnels n'apparaissent pas. Il faut construire sa configuration ici :
http://ckeditor.com/addons/plugins/all
A la fin une fenêtre récapitulative permet de cocher les options standard ou full qui ajoutent automatiquement les plugins nécessaires.

Les versions de licences ne sont pas claires, entre un site qui fournit d'office une version payante, et le site "officiel" on a du mal à s'y retrouver :(

Bonjour,
Pour ma part Drupal 7.22 + Wysiwig 7.x-2.2 + tinymce 3.5.8 / CKEditor 3.6.6.1.7696

Je n'y arrive pas ! Oui la solution évoquée plus haut (avec le module [http://drupal.org/project/ckeditor])marche parfaitement mais je ne peux pas l'utiliser car j'ai besoin du module footnotes pour mon wiki.
Je n'ai pas le choix, il faut que j'utilise Wysiwig + TinyMCE ou CKeditor.
Qui peut m'aider ?
Merci beaucoup...
RVB