Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Pb de modif de la limite mémoire en hébergt mutualisé

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

Suite à l'installation d'un Drupal 7.15 et l'activation d'un module gourmand (views) chez un hébergeur mutualisé (nommé blacknight), je suis tombé sur le classique problème du manque de mémoire php. J'ai bien vérifié et effectivement, je n'ai que 40Mb de mémoire php ...

On trouve facilement sur internet (ici par exemple : http://drupal.org/node/207036) les différentes solutions envisageables en environnement d'hébergement mutualisé : changement du .htaccess ou du settings.php (je n'ai évidemment pas accès au php.ini). J'ai esssayé les différents solutions proposées mais rien ne marche, la mémoire reste bloquée à 40M :(

Je suis donc entré en contact avec le support de blacknight (l'hébergeur donc) qui m'assure que la solution .htaccess doit fonctionner sauf que j'ai beau placer la ligne "php_value memory_limit 64M" pour changer la limite de mémoire, je n'arrive pas à changer cette valeur, elle ne bouge jamais.

Je suis donc un peu désespéré et je vais peut être devoir changer d'hébergeur, ce qui va me prendre du temps (et de l'argent !).

Donc si qq'un a une solution ou une piste pour résoudre le problème ou au moins pour essayer de comprendre ce qu'il se passe, je lui en serais extrêmement reconnaissant !

bien cordialement
Bernard VALTON

Version de Drupal : 

rebonjour,

je me répond à moi-même pour que personne ne perde son temps.

Ca y est, à force de tanner le support de mon hébergeur (blacknight), ils ont fini par s'occuper vraiment de mon problème et ils ont du modifier la conf php de leur côté car en tout cas, cela marche, ouf !

A moi les 128M de mémoire et l'installation d'un vrai site sous Drupal 7, chouette, je peux travailler !

bernard VALTON
http://drupaloo.info