Message d'avertissement

The subscription service is currently unavailable. Please try again later.

[résolu]Module imagemenu, supprimer les puces marche pas sur ie7, mais ok sur firefox,opera, safari

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Salut tout le monde,
Je m'arrache la tête à force de ne pas trouver :
J'ai installé le module imagemenu, et comme mon thème met des puces pour les listes, j'ai modifié le css de imagemenu comme suit :

.imagemenu .leaf {
list-style: none;
background: none;
}

.imagemenu .leaf a:hover,
.imagemenu .leaf a:focus {
border-bottom: none;
text-decoration: none;
}

.imagemenu .expanded {
list-style: none;
background: none;
}

.imagemenu .expanded a:hover,
.imagemenu .expanded a:focus {
border-bottom: none;
text-decoration: none;
}

.imagemenu .collapsed {
list-style: none;
background: none;
}

.imagemenu .collapsed a:hover,
.imagemenu .collapsed a:focus {
border-bottom: none;
text-decoration: none;
}

La commande "list-style: none;" fonctionne dans tous les browsers que je connais sauf... IE7 (pour changer).
J'ai essayé en ajoutant des lignes comme "-list-style: none;",
"*list-style: none;" etc. etc. mais rien n'y fait.
Quelle est la recette pour faire disparaître ces satanées puces dans mon menu "imagemenu", évidement sans modifier le menu de navigation standard ?
Heeeeeeeeeeeeelp, j'en peux plus.
Merci d'avance à ceux qui peuvent me mettre sur la piste

ps : je découvre php et css en même temps que drupal (4 semaines au plus)

Version de Drupal : 

Alors, je ne sais vraiment pas si ça va t'aider, je suis débutante, mais j'ai réussi a suprimer les puces des menus sous ie en ajoutant a mon style css :

ul li, ul.menu li, .item-list ul li, li.leaf {
list-style-type: none;
list-style-image: none;
}

C'est pas que c'est mort, mais sans avoir la page en question sous les yeux, les questions de CSS sont assez dur a répondre. ("juste" definir un style n'est pas forcement toujours suffissant, si par derriere le style est a nouveau defini quelque part, via des selecteurs de poids plus elevé (plusieurs class, id, ...), ta redefinition sera simplement ignorer.
Ajoutons a celà les spécificité des differents nagivateurs, et on a un joli... "bordel" ^^

Bonjour a tous.

Je suis en train de migrer ce site drupal 5 en drupal 6.
J'ai bien migré le core et suis en train de mettre a jours les autres modules.
Donc 1er module non core que je met a jour : ImageMenu, je lance update.php il me met une erreur comme quoi le champ "target" existe déja ou est en doublon dans ma table imagemenu ... je regarde avec phpmyadmin il ya bien le champ "target" dans ma table imagemenu ... par contre impossible d’accéder a imagemenu en passant par admin/menu (comme c'est le cas avec drupal 5) il faut aller dans admin puis passer en mode "par module" et aller dans imagemenu et la j'ai une erreur comme quoi le champ "description" n'existe pas dans la table imagemenu ! Je crée donc un champ "description" dans la table imagemenu avec phpmyadmin (bon le Pb c'est que je sais pas quel type il faut, je mets "char(0)" pour tester) et la ça fonctionne ...

Mais si quelqu'un peut m'en dire plus sur ce champ description (son type et ce qu'il est censé y avoir dedans, je suis preneur)

Je m’aperçois maintenant qu'il y a une puce a chaque image !
Je modifie donc mon fichier imagemenu.css comme expliqué dans ce post mais ça ne marche pas ...

Test 1 (imagemenu.css):

.imagemenu .leaf {
list-style: none;
background: none;
}

.imagemenu .expanded {
list-style: none;
background: none;
}

.imagemenu .collapsed {
list-style: none;
background: none;

Test 2 (imagemenu.css):

.imagemenu .leaf {
list-style-type: none;
list-style-image: none;
}

.imagemenu .expanded {
list-style-type: none;
list-style-image: none;
}

.imagemenu .collapsed {
list-style-type: none;
list-style-image: none;
}

Test 3 (imagemenu.css):

ul li, ul.menu li, .item-list ul li, li.leaf {
list-style-type: none;
list-style-image: none;
}

rien a faire je dois faire une erreur mais je vois pas ...

Le site en cours de migration

SVP aidez moi !

On peut aussi surcharger les sélecteurs CSS, en ajoutant les mêmes règles dans le thème utilisé, ou en affinant un peu.

Sinon, en cas de mise à jour, les modifications seront perdues, à moins de penser à réappliquer les modifications

Oui merci, effectivement vaut mieux le faire dans le theme (style.css) ...

J'ai donc mis dans mon style.css la modif qui fonctionné dans system-menus.css :

li.leaf {
list-style-type: none;
list-style-image: none;
}

Puis j'ai compris que l'on pouvait spécifier uniquement ce block :

#block-imagemenu-1 li.leaf {
list-style-type: none;
list-style-image: none;
}