Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Erreur au lancement du sript de mise à jour - Hebergeur OVH

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,

Hébergé chez OVH, j'ai mis à jour ce matin le module Administration Menu.
En lançant le script de mise à jour de la base donnée, j'obtiens ce message :

The update process was aborted prematurely while running update # in .module. All errors have been logged. You may need to check the watchdog database table manually.

Puis l'erreur suivante :

warning: array_pop() [function.array-pop]: The argument should be an array in /homez.313/monsite/www/update.php on line 313.

Qu'est ce que cela signifie ? Et que faire ?
Merci d'avance,

Cordialement,

Thib

Version de Drupal : 

RE-bonjour,

J'ai sans doute un problème de PHP, J'ai mis en ligne hier et je me souviens que j'avais eu également l'erreur de type PHP suivante (par contre je ne me souviens plus du contexte...) :

file_get_contents(sites/default/files/languages/fr_f55140c8170e17a29459b8229c9b6349.js) [function.file-get-contents]: failed to open stream: No such file or directory dans /homez.313/monsite/www/includes/common.inc à la ligne 2467.

J'ai développé le site en local sous PHP 5.3 et chez OVH c'est du 5.2.17 de plus ma base de donnée mySQL de développement était en 5.1.36 alors que chez OVH c'est en 5.0.90...
Est-ce que ça peut venir d'un de ces paramètres ??

Cordialement,

Thib

EDIT : Je viens de voir que je ne pouvais plus non plus importer de traduction avec le module Localization Update...

RE re Bonjour,

Ca avance...
Je suis passé en PHP 5.3 et maintenant j'ai cette erreur :

An HTTP error 403 occurred. http://www.monsite.fr/update.php?id=190&op=do

Puis quand je me rend sur la page d'erreur, j'ai toujours ce message :

warning: array_pop() expects parameter 1 to be array, boolean given in /homez.313/monsite/www/update.php on line 313.

En fait je ne suis pas certains que le changement de version PHP y ai fait quelque chose...

Donc apparemment c'est un problème de droit !!!
Que dois-je donc faire ? (J'ai vu sur d'autre post qu'il était question de chmod mais je ne sais pas où ni comment m'en servir)

Merci d'avance,

Thib

Bon eh bien j'ai trouvé ce post : http://drupalfr.org/forum/support/support-general/8314-resolu-erreur-lor... avec une erreur semblable, et effectivement, le problème vient de Firefox qui doit sans doute mal gérer le JavaScript... Etonnant non ?!

J'ai utilisé Internet Explorer pour faire la mise à jour et tout s'est parfaitement bien déroulé...

Que faire pour Firefox ? Ne plus l'utiliser ?

Cordialement,

Thib

warning: array_pop() [function.array-pop]: The argument should be an array in www/update.php on line 313.

j'en remets juste une couche pour aider d'éventuelles recherches, car je viens d'avoir le problème avec la mise à jour de "chaos tools suite" et le changement de navigateur (de firefox à chrome en l'occurrence) a résolu le problème.