Message d'avertissement

The subscription service is currently unavailable. Please try again later.

argument : "User UID is Author" ne foncionne pas HELP !

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Je souhaite afficher d'autres nodes du meme auteur dans ses nodes dans un block.

L'argument : User: UID is Author Display all values.
Argument Handling Code :

if ($view->build_type == 'block' && arg(0) == 'node' && is_numeric(arg(1))) {
  $node=node_load(arg(1));
  $args[0] = $node->uid;
}

Cela m'affiche des resultats...
disons que j'affiche 5 nodes dans le block :
Les 2 1eres nodes sont bien du meme auteur, mais les suivantes, NON !

Et si je vais sur la page d'une node d'un autre auteur, cela m'affiche exactement la meme chose.

AIDER MOI !!!!

J'ai du creer des modules pour faire cela, mais je compte sur le module Views pour le faire plus simplement.

merci !

Version de Drupal : 

Juste un doute comme ca vu que tu as mis "Display all values", t'es sur aue ton bout de code retourne bien qqch ???
J'ai comme l'impression que non, ptet parce que $view n'est pas defini a l'appel de ta page, donc ta vue retourne toutes les valeurs et pas seulement les nodes de ton auteur... Par chance les 2 premiers de ta vue son de cet auteur mais pas les autres et l'argument n'est pas pris en compte.

Oui cela retourne quelque chose, mais comme tu l'as compris, cela retourne n'importe quoi.
Que veux-tu dire par : $view n'est pas defini a l'appel de ta page

j'ai testé avec l'argument node id, avec, sans code handline, en table, en liste, etc...Rien ne fonctionne.

J'ai pourtant verifié sur drupal.org, je vois pas ce qui cloche..

J'ai du oublié quelque chose, mais...quoi !?