Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Mettre mon forum aux couleurs du site

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonsoir les gens,
Voilà quelques heures que je planche sur le sujet...
J'ai un site qu'il est tout joli avec son thème denver hypra customisé... mais le forum lui, il est tout moche... avec son bleu, son gris et son teste blanc invisible sur gris.... Qui c'est qui nous a fait un truc pareil?! Appelez moi le directeur! Loll
Bref, dans le genre pas démontée, je me suis dit "pas grave, on va mettre les mains dans le cambouis" mais je suis une autodidacte de chez autodidacte, donc je frémis toujours d'avance.
Donc je décide d'aller voir du css...
Je bidouille le seul CSS associé au forum que je trouve sur mon chemi : advanced_forum.
Et là malgré mes beaux codes couleurs et tout... ça n'a affiché aucun changement? WTF?
So what?
Comment je fais moi pour avoir un joli forum?
Help me brothers & sisters...
Les dieux du ouèbe vous le rendront...
Merci!

Version de Drupal : 

Si tu veux modifier les CSS facilement (et c'est le moyen le plus simple d'améliorer l'apprence de ton forum), je te conseille d'installer firebug pour Firefox.

Il doit y avoir pas mal de déclarations héritées de style.css car le forum est un type de node.

Comme on l'a dis avant moi, on ne peux que te recommander de travailler avec l'extension Firebug pour Firefox. Ca te permettra d'identifier a coup sur les styles CSS qui sont utilisé sur les éléments que tu souhaites changer.

Par contre, il est recommander de ne pas toucher au fichier de ton module (advanced_forum donc là), donc, pas touche au advanced_forum.css.
Si tu as besoin de modifier une "déclaration" CSS, tu "copie/colle" celle-ci dans ton style.css (de ton theme) et tu la change dans le ce fichier là.
Toutes les déclarations qui se trouvent dans ce fichier sont proritaire sur le reste.
De cette maniere, tu peux garder l'ensemble des fichiers de ton module "clean" et il n'y a pas de risque en cas de mise a jours (le cas typique : ton module advanced_forum est mis a jours, tu envoies les fichiers, et y écrase ton advanced_forum.css… tu peux tout recommencer ^^).

Si les modifications ne sont pas prisent en compte immédiatement, regarde aussi du côté du cache. Désactive le pendant que tu fais tes tests.

N'est-ce pas ? ;)
En utilisant "l'onglet" HTML et le bouton "inspect" puis en pointant avec la souris l'élément que tu souhaites "voir", ca te rend bien des services.

Oui en effet c'est vachement bien...
Par contre à rectifier à la page css, j'ai fait une connerie... J'ai corrigé le module "event" dont les couleurs étaient certes momoches, mais comme je viens de rectifier le tire ds event.css, je me demandais comment forcer event.css à passer par dessus mes autres css pour que ce soient ces couleurs là et pas d'autres qui apparaissent...?
Merci
veroo!

Comme je l'ai dis plus haut : "ne pas toucher aux .css des modules"

Si tu as besoin d'y modifier quelque chose, copier/coller la déclaration dans ton fichier style.css de ton theme (/themes/ton_theme/style.css). Toutes les déclarations de ce fichier seront prioritaires.

Merci beaucoup Haza!
Je retiendrai la leçon! Je ne m'y referai pas prendre une 2eme fois!
Du coup, j'ai fait du ménage dans les css et c'est rentré dans l'ordre tout seul...
Encore merci pour ta patience...
veroo!

Re moi...
J'ai toujours un pb...
Mon nom de containeur de forum est invisible et je ne sais où le trouver, comment le faire apparaitre... Avec inspecter je le "vois" noyé dans le fond mais impossible de trouver comment lui attribuer une couleur, etc... Ce que je ne comprends pas, c'est qu'en plus la couleur basique du texte en lien ou pas n'est même pas celle de mon fond de containeur...
Merci de m'aider à percer ce mystère!
veroo!

Ooups... j'ai enfin trouvé après des heures de recherche que c'était mon #forum td.container a qui décelait l'erreur fatale... la couleur y était la même que celle du fond! Bon sang mais c'est bien sûr!
veroo!