Message d'avertissement

The subscription service is currently unavailable. Please try again later.

[Résolu] Comment faire pour... installer le module jQuery ?

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,
J'ai besoin du module jQuery pour mon site Drupal. Le problème, c'est que j'installe le module que j'ai telecharge sur Drupal.org dans /sites/all/modules, normal. Mais après il me dit "The jQuery plugin est manquant, veuillez le telecharger ici"
Je le telecharge je le mets dans le module et la, il me met plus le message mais par contre je ne peux pas cocher la petite case a cote du module jQuery.
Avez-vous la solution ou un tuto a me conseiller ?

Cordialement,
Thibault

Version de Drupal : 

Pareil pour moi !

Par contre je peux, selon le cas (!) cliquer sur la case jquery_ui mais après avoir cliqué sur enregistrer j'ai toujours le message rouge qui me demande de télécharger le fameux jquery alors que c'est déjà fait.

Je précise bien que j'ai bien décompressé le plugin .ZIP dans le dossier du module jquery_ui

Tout est dans le readme.txt sous

INSTALLATION --

Télécharger le module jquery_ui (http://drupal.org/project/jquery_ui)
Télécharger jQuery UI 1.6 sur le site de google (http://code.google.com/p/jquery-ui/downloads/list?q=1.6)

Décompresser le premier et le placer dans le dossier site/all/modules/jquery_ui
Décompresser le second, le placer dans site/all/module/jquery_ui/jquery.ui-1.6
Renommer le dossier jquery.ui-1.6 en jquery.ui
Les scripts jQuery UI sont donc dans /sites/all/modules/jquery_ui/jquery.ui/ui/*.js

Activez le module et c'est prêt :-D

Encore merci laevensv.

Me concernant :

  • je lis jamais les readme.txt et d'ailleurs j'ai téléchargé/installé d'autres modules sans soucis ! Mais la prochaine fois, promis, je les lirais, sauf que :

  • Je pige pas bien l'Anglais !

  • Je suis novice dans Drupal et ne savais pas ce qu'était un CMS il y a 10 jours...mais c'est pas une excuse ...

j'ai essayé cette solution, ainsi que celle du read me pour les jquery_ui-6.x-1.5 et jquery.ui-1.6, à savoir

* Copy the jquery_ui module directory to your sites/all/modules directory, so it
is located in sites/all/modules/jquery_ui/.

  • Download the jQuery UI 1.6 release from:

    http://code.google.com/p/jquery-ui/downloads/list?q=1.6

  • Put the downloaded archive into the directory:

    /sites/all/libraries/jquery.ui-1.6.zip

  • Extract the archive. This will create the following sub-directory:

    /sites/all/libraries/jquery.ui-1.6/

  • Rename the sub-directory into "jquery.ui":

    /sites/all/libraries/jquery.ui/

    so the actual jQuery UI JavaScript files are located in:

    /sites/all/libraries/jquery.ui/ui/*.js

en ayant donc jquery_ui dans sites/all/modules et jquery.ui dans sites/all/libraries pour cette solution, alors que dans l'autre solution jquery.ui est dans jquery_ui.

dans les deux cas, j'ai :
- The Date Popup module now requires the jQuery UI module as a source for the datepicker. Please install it immediately.
- j'ai bien "jQuery UI 6.x-1.5" dans ma liste de modules, mais la case est incochable

ps : le site tourne sous le thème corolla et a plusieurs modules