Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Installation de Drupal dans un sous-répertoire

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,

J'ai développé un site Drupal en local.
Après plusieurs galères lors de la mise en ligne à la racine de mon domaine, j'ai décidé de l'installer dans un sous-répertoire afin de faire tous mes paramétrage avant la mise en ligne officielle.

  • J'ai donc créé un dossier "/test" dans lequel j'ai uploadé la dernière version du site.
  • La base de donnée a également été placée chez mon hébergeur (ovh).
  • Mon "settings.php" a été actualisé avec les infos de ma base.
  • Le ".htaccess " a été modifié en ajoutant les lignes suivantes :
    SetEnv PHP_VER 5
    SetEnv REGISTER_GLOBALS 0
    SetEnv ZEND_OPTIMIZER 1
  • J'ai également testé en ajoutant un "RewriteBase /test"

Malgré tout cela je tombe sur un méchant : "500 Internal Server Error" lorsque je me rends sur "www.site.com/test"

Je suis sûr qu'il s'agit d'une bêtise mais je tourne en rond depuis des heures et votre aide me serai de la plus grande utilité.

Merci d'avance pour votre aide !

Version de Drupal : 

Repars du .htaccess du package drupal par défaut.
Ensuite fait tes modifs au fur et à mesure en testant entre chaque que tu arrives bien à accéder à la page d'accueil
1° SetEnv PHP_VER 5
2° SetEnv REGISTER_GLOBALS 0
3° RewriteBase /test
4° SetEnv ZEND_OPTIMIZER 1

Merci à vous deux pour votre aide et votre réactivité.

Effectivement, le problème venait bien d'une entrée dans le .htaccess
Lors de tests en local j'avais ajouté la ligne suivante :
php_value memory_limit 1024M

Après omparaison avec le fichier de base, je me suis rendu compte qu'elle n'existait pas.
Désormais le site fonctionne dans le sous-répertoire !