[aide] base de drupal

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,

je me permets de vous demander un petit coup de main par rapport à Drupal, étant un vrai débutant avec ce cms, je bloque sur quelques trucs évident pour la plupart d'entre vous :)...

J'ai exactement 3 questions à vous posez:

  1. Dans mon site j'ai créé une page avec un diaporama, jusque la tout va bien, il marche comme je veux, le problème est le suivant, lorsque je me délog de drupal, je clique sur la page et aucun diaporama ne s'affiche :/

  2. J'ai intégré un formulaire de contact de drupal, qui s'affiche également bien quand je suis logué sur drupal mais lui, le lien disparait carrément du menu et donc pas moyen d'arriver sur la page contact

  3. J'ai développé mon site en ligne, sur le ftp de mon site, quel dossier dois je mettre à la racine de mon site afin que lorsque je tape www.monsite.be s'affiche? j'avoue m'y perdre un peu dans dans tous ses dossiers...

Un grand merci pour votre aide :)

Les liens et pages qui disparaissent lorsque tu te délogues c'est un problème de droit. C'est à dire que tes utilisateurs anonyme n'ont pas accès à ton diaporama et à ta page contact. Regarde dans les permissions utilisateurs pour "Anonyme" et coche les BONNES cases.

ok je vais bien checker tout ca

sinon pour le moment c'est structuré ainsi dans mon ftp: /www/Drupal/files/...

sur les conseils d'un amis, j'ai mis le thème de mon site dans /www/Drupal/files/sites/all/themes...

j'espère avoir été assez complet..

merci pour ton aide

oui il existe à la racine du dossier www

se trouve déjà dans le fichier htaccess: SetEnv PHP_VER 5, j'ai ajouté ta ligne mais rien ne change :/

par contre je comprend pas trop comment retrouver l'index car je ne vois dans aucun de mes dossier un index.php ??

Hum pourquoi node se trouve t-il dans files? tout tes fichiers de Drupal se trouvent dans le dossier files ? Tu as donc crée un sous répertoire ?
Ne veux-tu pas que je jette un oeil sur ton ftp ? Confiance oblige...

oui effectivement tout se trouve dans le sous répertoire files :/ (j'ai créé ce dossier en suivant un tuto :/)

ne le prend pas mal mais j'ai déjà eu des mauvaises blagues par le passé donc je préfère pas trop...

je peux faire des printscreens si tu veux... en tt cas c'est bien sympa de prendre du temps pour moi ;)

Bonjour, j'ai profité de ce post pour revoir l'installation de mon site que j'avais mis en direct sous www et que je n'osais pas déplacer par crainte de tout casser.
Je l'ai donc déplacé sous www/monsite.
Comme waly, je n'y accédais plus directement.
J'ai déplacé le .htaccess du site sous www, en modifiant comme tu l'indiquais le DirectoryIndex. Parfait, j'arrivais à nouveau sur le site.
Mais dès que je voulais changer de page, il ne trouvait plus le fichier index.php.
J'ai donc recopié l'ancien .htaccess sous www/monsite, et là, je retrouve tous mes petits
Mais ça ne me semble pas très élégant d'avoir 2 .htaccess, surtout si je veux rajouter un autre site (ce qui n'est pas d'actualité) sous www.
Ce serait un problème de DNS et de redirection? Là, je dois dire que je rame un peu.
Alors merci si tu as une solution simple.

Non, ça ne veut pas fonctionner si j'enlève le .htaccess du www.

J'ai alors la page "Index of" qui affiche le contenu du répertoire.
Pour info, mon site http://signe-bobd.fr/ est stocké dans www/bobd.fr
Est-ce parce que le nom du domaine est différent du nom du dossier?

En fait, je n'arrive pas à m'en sortir entre les 2.
C'est aussi pour moi un 2ème problème:
J'ai un nom de domaine signe-bobd.fr chez OVH avec son hébergement et un nom de domaine bobd.fr chez Gandi.
J'essaie de faire pointer bobd.fr sur l'hébergement OVH, mais sans réussir à remplacer le signe-bobd.fr.