Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Peur de MàJ et conseils...

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

Je suis le "webmestre" d'aspag.fr. Ce site tourne depuis 1 an et demi, et, depuis, drupal a continué à évolué.
Habitué des logiciels libres, je sais qu'il est préférable de suivre les MàJ régulièrement, mais là, c'est un site communautaire, pas MA machine, je ne veux donc pas tout casser et rendre le site indisponible pendant trop longtemps. Et comme je ne maitrise pas trop les technologies, tant que ça marche...

Voilà ce que j'essaierai volontiers de faire:
-installer un nouveau site DRUPAL en // avec l'ancien;
-le mettre au point: ajouter les modules, le configurer sans contenu ni autre utilisateur que des comptes de test;
-importer la bases de données (utilisateurs, articles...);
-vérifier que tout fonctionne sur les 2 versions en demandant à ne pas/interdisant de poster pendant ce temps là
-basculer sur le nouveau site

Un souci MAJEUR (me semble-t-il): l'abonnement bas prix de l'hébergeur ne comprend qu'UNE base de donnée. Le site étant petit, elle est très loin d'être pleine: j'espère donc pouvoir m'en sortir en jouant sur des préfixes ou suffixes sur les noms des tables...

À votre avis, est-ce jouable sans risque inconsidéré? Quelle version me conseillez vous pour cela (Je pars de DRUPAL 4.6, installé à partir de la "distribution" civicspace 0.8.4.). Pour être tranquille plus longtemps, je préfèrerai une version qui restera d'actualité pendant encore quelques temps, sans toutefois chercher une solution beta ou même RC...

Merci d'être arrivé jusque là :-)

Didier

Version de Drupal : 

Tu dois en effet pouvoir installer 2 drupal en // avec les prefix de tables (mais je l'ai jamais fait personellement). La version stable actuelle est la 5.3. La version 6 est encore en béta.
Moi personnellement je m'y serais pris autrement.
J'aurai d'abord fait une copie de mon site en modifiant les préfixes.
Ensuite j'aurai upgradé mon nouveau site.
Une fois l'upgrade finie, il suffit de mettre hors ligne le précédent.

L'avantage c'est de faire une upgrade "normale" et non pas un transfert plus ou moins hasardeux.
Un tuto d'upgrade : http://drupal.org/videocasts/upgrading-to-5

Sinon tu as l'autre solution : tu fais un backup de ton site et tu tente l'upgrade a un moment ou le site est "tranquille" (du genre la nuit ?). En cas de problème, tu reviens en arrière.
Ca me semble encore le plus simple.

Il faudrait cependant upgrader de 4.6->4.7, puis de 4.7->5.x, au minimum 2 étapes donc, non? Ce qui rends l'opération encore plus hasardeuse et longue, car il ne s'agit pas uniquement de Drupal, mais de (Drupal+plein de modules)...

À moins que l'upgrade des modules ne soit pas nécessaire? Si j'upgrade juste "le coeur" et installe d'autres modules, est-ce que je risque qqch d'autre que de longues reconfiguration? (par ex, si les modules de gestion des permissions ne sont pas les mêmes, il faudrait que je reprenne les perm de chaque utilisateurs, qui ont été attribuées au fur et à mesure... Je ne sais pas si mon ex est clair et pertinent...)

Oups...
Perso qd je vois "DRUPAL 4.6, installé à partir de la "distribution" civicspace 0.8.4" ca me rassure pas top top...
1/ CivicSpace est une distribution de Drupal bien particuliere et avec un max de personnalisation (notamment l'integration de CiviCRM)
2/ j'ai un peu l'impression qu'ils sont passes sur un modele SaaS du coup y a plus moyen de le telecharger

Bref perso je te conseillerai de commencer a migrer ton site vers une version officielle de Drupal.

Bon courage

Oui, malheureusement, CivicSpace n'est plus maintenu sous la forme d'alors... Il m'avait semblé à l'époque que la majeure partie de la personnalisation tenait en une installation automatique de modules choisis et ne posant pas de pbs entre eux... voire configurer/modifier pour ne plus en poser.
Il me semblait cependant que le coeur de Drupal restait la version officielle, ce qui me laissait espéré la possibilité de la MaJ...

Quelles seraient les étapes d'une migration vers «une version officielle de Drupal.»

Completement a la louche, je dirais
- installer une 4.6.x
- comparer les tables qui ont des donnees pour esperer ne pas avoir de donnees ds des tables de civicspaces qui n'ont pas d'equivalent sous la 4.6
- verifier le contenu de tables comme variables, system pour voir si y a pas trop de trucs qui sont de civicspace
- importer les donnees des tables importantes: node, user, role, term (_node, _data)...
- verifier que le contenu est tjs la
- une fois que tout est en place (sauf le template) commencer a faire des upgrades vers la 4.7 et ensuite 5

S'armer de courage et de tps ;)