Message d'avertissement

The subscription service is currently unavailable. Please try again later.

comment supprimer le Spellchecker SCAYT de CKeditor ?

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

Je cherche à désactiver la fonction spellchecker de CKeditor puisqu'il me souligne tous les mots, anglais par défaut inside.

Malheureusement je trouve rien dans l'admin. Je dois éditer un fichier à la mano je suppose ?
Je précise que je l'ai installé en tant que librairie via Wysiwyg.

Merci de votre aide.

J'ai testé avec succès la solution proposée dans ce post :

http://drupal.org/node/837940#comment-3192162

Pour désactiver SCAYT :

1- Aller dans la page d'administration de CKeditor (http://yoursite/admin/settings/ckeditor)

2- Sélectionner le profil, puis dans les paramètres « Options avancées » coller le code suivant dans le champs « Configuration personnalisée de javascript » :

config.scayt_autoStartup = false;

3- Enregistrer les modifications.

Ensuite il peut être utile de désactiver les boutons correspondant au SpellChecker si vous utilisez une toolbar qui les propose.
Pour cela : éditer le fichier ckeditor.config.js (sites/all/modules/ckeditor)

Pour ceux que ça intéresse, comment désactiver le spellchecker de CKeditor installé par le module wysiwyg:

En fait le module wysiwyg envoie ses propre configurations sans tenir compte des fichiers de configurations existants dans le répertoire de Ckeditor.
Le hic, c'est que wysiwyg ne fournit pas d'interface pour modifier ces paramètres...

Donc pour modifier ces paramètres proprement, une fois n'est pas coutume, il faut passer par un hook défini dans un module.

tests réalisés avec succès d'après le billet http://drupal.org/node/313497#comment-2609628

function MONMODULE_wysiwyg_editor_settings_alter(&$settings, &$context) {
  if($context['profile']->editor == 'ckeditor') {
    $settings['scayt_autoStartup'] = false; // pour désactiver le lancement de scayt (spellchecker de Ckeditor)
    $settings['scayt_sLang'] = 'fr'; // Si vous préférez l'avoir en français
  }
}

du coup, les autres config, ça marche de la même manière...