Message d'avertissement

The subscription service is currently unavailable. Please try again later.

'Save' inactif dans FCKeditor

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Salut,

J'essaie de mettre à jour sur drupal 6.17 :
- le module FCKeditor 6.x-1.4 vers 6.x-2.1
- FCKeditor 2.6.5 ver 2.6.6

J'ai donc répercuté mes customisations diverses (barres d'outils et utilisation d'Image Assist). Tout fonctionne, sauf... le bouton "Enregistrer" de l'éditeur. Il est visible mais ne valide pas le formulaire.
Ça vient de la mise à jour du module drupal : la version 6.x-1.4 fonctionne normalement avec FCKeditor 2.6.6

À noter que je n'utilise pas WYSIWYG.

une idée?

Version de Drupal : 
Tags : 

Personne n'a rencontré ce problème? Pourtant, même en installant FCKeditor 6.x-2.1 et FCKeditor 2.6.6 bruts de fonderie, en ajoutant juste le bouton 'Save' dans fckeditor.config.js, celui-ci apparaît mais reste inactif.

Est-ce voulu?

Est-ce "réparable"? En tout cas mes utilisateurs ont besoin du bouton 'Enregistrer' pour faire de courtes modifs sans aller jusqu'en bas du formulaire.

C'est réglé, la solution était dans la version dev.

Ajouter simplement à fckeditor.utils.js à la fin de le fonction FCKeditor_OnComplete() en ligne 202 :

// The save button in the FCKeditor toolbar needs the form property
editorInstance.LinkedField.form = editorInstance.LinkedField2.form;

C'est parti pour FCKeditor 2.1 !