Bug d'install rien ne se passe

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

bonsoir,
j'essaye d'installer drupal sur WAMP SERVER windows 7;
il me demande le nom de la basse de donnees + login
lorsque je valide le formulaire il revient avec les
champs vides sur mon formulaire sans message d'erreurs,

sur mon autre pc sous vista
tout fonctionne bien
merci de vos reponses.

Version de Drupal : 

Bonsoir,

J'ai également le même problème. Il m'est impossible d'aller plus loin que la sélection de la BDD.
J'ai l'utilisateur root, sans mot de passe de créé.
Je suis nouveau sur drupal et je veux pouvoir l'utiliser pour mon activité d'indépendant.
S'il vous plaît, si quelqu'un a une idée du pourquoi ça ne fonctionne pas sur Windows 7, ça serait sympa de partager vos connaissances.

Merci d'avance.

Configuration :

Windows 7 Pro
Wampserver 2.0
PHP 5.3.0
MySQL 5.1.36

J'ai trouvé , pour mon cas 2 fichiers doivent s'appeler respectivement dans le dossier
\sites\default : settings.php et default.settings.php

Avant l'install faire une copie de "default.settings.php" , le fichier copié doit être nomé exactement "settings.php"

concenant mon cas il s appelait "default.settings - Copie.php" ERREUR DE DEBUTANT je l'admais.

Guillaume.

Bonjour Thib,

Et non, la version de PHP n'a rien à voir à part le fait qu'il y ai pas mal de fonction DEPRECATED (pour PHP 5.3, bien sûr) mais un petit tour dans le php.ini pour modifier ceci :
error_reporting = E_ALL & ~E_DEPRECATED

Sinon, il y a bien 2,3 erreurs mais rien de bloquant en fait.

Mais, effectivement, pour mon problème initial, c'est également une erreur de débutant souligné par gseverin.

En sommes, pour que cela fonctionne correctement sans enlever l'affichage des warnings concernant les fonctions DEPRECATED, il faudrait remplacer toutes les fonctions POSIX Regex (ereg_replace, ereg, eregi_replace, eregi, split, spliti et sql_regcase) par leurs équivalent PCRE.
Pour le reste, cela a avoir avec la fonction call_user_func_array() qui demande que le tableau d'argument soit passé par référence et non par valeur comme actuellement et j'ai trouvé un FIX pour ça mais rien de très propre sur PHP.net :

$Args = array();

foreach($args as $k => &$arg){

$Args[$k] = &$arg;

}

et c'est la variable $Args et non pas $args qu'il faut passer à la fonction.

Cela fonctionne, je l'ai testé ce matin.

Si cela peut aider quelqu'un, j'en suis ravi.

@+

EDIT :

Je me suis un peu avancé sur la facilité de la chose, mea culpa :)
C'est bien plus compliqué que cela et le mieux et de revenir sur PHP 5.2x dans sa version la plus récente.
J'attendrais une nouvelle version de Drupal6 qui prendra en compte PHP 5.3.
Encore désolé pour la pollution du topic avec mes solutions à deux balles.