Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Installation de TinyMCE (Par le module Wysiwyg)

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour

Je souhaiterais installer TinyMCE.

J'ai suivit les conseils de Drupal sur TinyMCE

Donc j'ai installé le module Wysiwyg.
Je suis aller dans la rubrique: Administrer -> configuration du site -> Wysiwyg

J'ai cliqué sur Download pour le module TinyMCE est j'ai téléchargé le pack: tinymce_3_3b2.zip.

J'ai décompressé le pack dans: sites/all/libraries/

Une foie fait, je retourne dans Wysiwyg et je trouve cette erreur:

The version of TinyMCE could not be detected.

Extract the archive and copy its contents into a new folder in the following location:
sites/all/libraries/tinymce

So the actual library can be found at:

sites/all/libraries/tinymce/jscripts/tiny_mce/tiny_mce.js

A ce moment là, je prend tous les fichiers du dossier tiny_mce et les mets dans le dossier tinymce mais ça ne marche toujours pas! Je vais devenir fou avec ce tinyMCE!!

Si quelqu'un pourrait m'aider, ça serait vraiment gentil!

Clément

Version de Drupal : 

Salut.

La réponse ne sera pas plaisante : j'ai cherché à faire la même chose la semaine passée, et rien à faire je n'ai pas réussi non plus à l'installer (même message d'erreur et même tentatives de solution...). :-))

Par contre j'ai réussi à installer : FCKeditor, jWYSIWYG, NicEdit et openWYSIWYG assez facilement. (De mémoire qq soucis avec FCKeditor/CKeditor tout de même. Il faut le décompresser 2 fois et avec lui, ça marche...)

D'un coté ça m'embête et d'un autre ça me rassure, je me dis que je ne suis pas totalement fou...

J'ai bien installé FCKeditor et aussi nicEdit mais pour un de mes problèmes, il faudrait que j'installe ce fameux tinyMCE.

Est-ce que je peux utiliser sans risque l'ancienne installation pour ce faire?

Avant, pour installer tinyMCE, il me semble qu'il fallait déjà installer un premier module qui s'appelait aussi tinyMCE mais apparemment il est déconseillé de le faire.

Dans tous les cas merci pour avoir répondu à ma question.

Salutations.
Clément

pour la version TinyMCE 3.3.9.1, une indication en plus de la lecture du patch ci-dessus car j'ai mis un certain temps avant de la trouver.

En lisant http://drupal.org/node/695398) , on apprend qu'il faut suivre http://drupal.org/files/issues/wysiwyg_110_version.patch

c a d qu'il faut mettre

$line = fgets($script, 110);

a la place de

$line = fgets($script, 100);

Je ne vois pas où ce tuto régle le problème d'installation du module TinyMCE, il explique comment installer le module IMCE non? Par contre dans un avenir proche je vais surement l'installer pour la gestion des images.