Message d'avertissement

The subscription service is currently unavailable. Please try again later.

url simplifiés

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous et à toute.

Alors juste une petite question a propos des urls simplifié en local et son mamp (mac)

je cherche donc a activer l'url simplifié mais en vain..

j'ai donc configuré httpd.conf dans le dossier apache en activant "LoadModule rewrite_module modules/mod_rewrite.so"

mais lorsque que je relance mes serveurs avec mamp et que j'ouvre drupal je ne peut pas cocher "Activer URL simplifié"

j'ai le module Path d'activé

Ca ne serais pas dans la configuration de mamp ->préférence -> apache -> Document root

Ca ne serais pas ici qu'il y a un probleme.?

j'ai actuellement comme chemin /Applications/MAMP/htdocs alors que mon dossier apache ne correspond pas au chemin indiquer et quand je cible le dossier apache plus rien ne marche.

Si vous avais une petite idée pour m'aider

Merci

Ludo

Version de Drupal : 

Jettes un oeil au .htaccess de ton instance drupal

il faut bien configurer le RewriteBase genre si ton site local a une url du genre
htt://127.0.0.1/monSite

n'oublie pas de mettre RewriteBase /monSite dans le .htaccess

le fichier existe de base pour toute install drupal.

par contre si tu essayes de le trouver en parcourant avec eclipse par exemple tu ne le verra pas. Sous linux il est caché parce qu'il commence par un "."
il se trouve au même niveau que le dossier /sites ou /misc

Je m'arrache les cheveux..
j'ai donc afficher les fichiers avec (.????)

Maintenant dans mon htaccess présent dans dossier /files je n'ai que 3 lignes de code..

Si je rajoute la ligne de code que tu m'a donné a la fin ca ne marche pas.

L'adresse de mon drupal est : http://localhost:8888/drupal-6.15

J'ai donc que ca dans mon htaccess :

SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006

Options none

Options +FollowSymLinks

RewriteBase /drupal-6.15

désolé et merci pour t'es réponses.

Ludo

Désolé de venir m'accrocher à ce fil, mais il correspond pile poil à mon cas.

Je suis parti de zéro et c'est pas cool :)

Quand je tente d'ouvrir mon site, j'ai le message :

'The requested URL /drupal/ was not found on this server.'

Je suis sous Mac+MAMP avec la configuration suivante :

Apache/2.0.59 (Unix) PHP/5.1.6 DAV/2 Server at localhost Port 8888, mod_rewrite chargé

le localhost pointe chez moi sur un répertoire spécifique (_weblocal) dans lequel j'ai plusieurs sites en test. Tous fonctionnent parfaitement. J'ai trouvé le .htaccess dans sites/default/files avec les 3 mêmes lignes que pour abraxasludo. Je l'ai complété avec :

RewriteBase /drupal

le chemin habituel pour lancer drupal étant :

http://localhost:8888/drupal/

je l'ai placé dans ce répertoire et paf!! plus d'accès ??

Je le supprime et je retrouve mon site (sans les URL simplifiées donc)

Je ne comprends ce qui se passe... si vous avez une idée, grand merci à vous

Je suis également dans le même cas, en local. J'apprends à me servir de Drupal, et ai suivit toutes les infos possible.

j’ai donc configuré httpd.conf dans le dossier apache en activant «LoadModule rewrite_module modules/mod_rewrite.so» (Sous Apache)

j’ai le module Path d’activé

Et j'ai aussi modifier le chemin du ficheir htccess de Drupal. Mais rien ne peut-être sélectionner dans la prtie urls simplifiés.

Je desespère car cette fonction est primordial pour Imagecash, imagegallery ...