Message d'avertissement

The subscription service is currently unavailable. Please try again later.

afficher l'image de l'auteur dans la node?

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

bonjour,
cela doit etre simple mais je ne trouve pas !!

merci

Version de Drupal : 

Hello !

Il faut déjà activer les portraits, dans "Gestion des utilisateurs" -> "Paramètres", onglet "Portrait", activer le support des portraits utilisateurs, puis indiquer le répertoire de stockage et l'image par défaut.
Ensuite, il faut configurer le thème (admin/build/themes/settings dans la V5), dans la zone "Activer/désactiver l'affichage", cocher "Portrait des utilisateurs dans les contributions".
Je te réponds pour la V5, j'espère qu'il n'y a pas trop de changements par rapport à la 4.7...

A+

merci pour ta reponse mais malheureusement c'est pas du tout pareil pour la 4.7. Je cherche le code php qui doit etre un truc du genre <?php print $author->picture ?>.

Malgrés des recherches je n'ai pas trouvé.
je peux afficher l'image de l'utilisateur connecté bien sur, mais pas celle de l'auteur d'un node...

Sans vouloir insister, je viens de vérifier sur la 4.7, c'est quasi identique.
Si les images n'apparaissent pas, c'est peut-être que tu utilises un thème personnalisé dans lequel l'appel aux images est manquant. Essaie avec le thème bluemarine pour voir ce qui se passe...

ok j'ai trouvé !!

mais ya un truc qui cloche :

Images d'utilisateur dans les contributions

coché mais elles ne s'affichent pas..

Images d'utilisateur dans les commentaires

décoché mais elles s'affichent...

Sinon avec le theme bluemarine l'image s'affiche.
Je jette un oeil aux templates.