[REsolu]View et champ exposé

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

Il me semble avoir déjà vu un sujet de quelqu'un qui avait le même problème mais je n'ai pas su le retrouver.

Voila, j'ai une vue avec un champ exposé permettant de faire un tri pour l'utilisateur, le truc c'est qu'il apparaît dans l'écran de paramétrage mais pas dans mon bloc où il est affiché.(j'ai bien indiqué ne pas mettre en cache, et le cache de mon navigateur est désactivé)

Est-ce qu'il y a une opération spécifique à faire? Dans le paramétrage du champ exposé?

Merci d'avance

PS : il s'affiche bien en mode page

Fichier attachéTaille
Icône image views.jpg183.96 Ko
Icône image views2.jpg40.45 Ko
Forum : 
Version de Drupal : 

Le problème est que lorsque tu expose tes critères de tri, le bouton submit tente de te renvoyer vers la page de présentation de la vue.

Ce n'est pas très compatible avec le fait de définir la vue comme étant un block.

Il est préférable de définir ta vue comme étant une page et de travailler le template de cette page pour y ajouter les éléments que tu souhaites.

voir le lien "Thème:Informations" pour savoir quel template utiliser.

Tu peux en profiter pour placer tes critères de tri dans un block (paraméter le champ Exposed Form in Block à Oui et placer le block dans ta page)