Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Comment activer les Clean URLs en local avec Wampserver 2.0? [résolu]

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonsoir, d'après mes recherches drupal.org/node/256410 , je n'arrive toujours pas à activer les clean urls...

  1. J'ai bien le fichier ".htaccess" dans mon répertoire principal et 2. il n'est pas corrompu.

  2. Je pense qu'en local, je n'ai pas besoin de modifier le "RewriteBase" du fichier ".htaccess":
    J'a essayé pas mal de solutions:

    Modify the RewriteBase if you are using Drupal in a subdirectory or in a

    VirtualDocumentRoot and the rewrite rules are not working properly.

    For example if your site is at http://example.com/drupal uncomment and

    modify the following line:

    RewriteBase /drupal-6.4
    #

    If your site is running in a VirtualDocumentRoot at http://example.com/,

    uncomment the following line:

    RewriteBase /

Vu que mon adresse est http://localhost/drupal-6.4/, je pense que ça devrait être bon

  1. Mon Apache rewrite rule n'est pas été modifié, c'est:
    RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
    donc c'est bon ici aussi.

Sinon j'ai modifié le fichier "httpd.conf" de Apache:

J'ai activé le "LoadModule rewrite_module modules/mod_rewrite.so" en enlevant le #.

Options FollowSymLinks
AllowOverride All <------------ J'ai mis "All" au lieu de "None"
Order deny,allow
Deny from all

AllowOverride All <------------ J'ai mis "All" au lieu de "None"
Options None
Order allow,deny
Allow from all

Voilà et en ayant fait tout ça, je ne peux toujours pas activer les Clean URLs dans "admin/settings/clean-urls"

J'aurais vraiment besoin d'aide svp ^^ Je suis carrément bloqué là.. ¨¨

Merci d'avance

Julien

Forum : 
Version de Drupal : 

Et quelques minutes plus tard après avoir passé 15 min à écrire ce post...

N'oubliez pas de redémarrer WAMP... ou du moins qu'Apache, et ça marchera ^^

Au moins ce post servira à d'autres personnes pour les Clean Urls ^^