Message d'avertissement

The subscription service is currently unavailable. Please try again later.

[Résolu] Problème d'arguments ou autre dans views...

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,

J'ai un type de contenu "Album" qui contient les champs suivants :

  • Titre (champs texte)
  • Couverture de l'album (champs image)
  • Description (champs texte)
  • Illustrations (champs image) x6 max

Je crée une vue pour que les illustrations d'un album apparaissent dans un bloc sur le nœud correspondant à l'album.

Je me dis alors que je vais utiliser en arguments "noeud : Titre" et dire de le récupérer dans l'URL mais ça ne fonctionne pas...

Comment me conseillez vous de procéder ?
D'avance merci,
Cordialement,

Thib

Forum : 
Version de Drupal : 

Bonjour,

«Node : nid» comme argument me semblerait plus adéquat puisque c'est ce que partagent tous les éléments de votre type de contenu. Avec « fournir l'argument par défaut» et «identifiant du noeud à partir de l'URL» comme option dans 'Action à mener si l'argument est absent', cela devrait pouvoir fonctionner.