Message d'avertissement

The subscription service is currently unavailable. Please try again later.

"max_allowed_packet" chez OVH

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,

Savez-vous s'il est possible de modifier la valeur de "max_allowed_packet" du fichier my.cnf chez ovh avec un serveur mutualisé ?
J'ai essayer de différentes manières mais le résultat est le même :

Warning: Got a packet bigger than 'max_allowed_packet' bytes query: UPDATE cache SET data = 'a:322:{s:13:"theme_default";s:14:"fusion_starter";s:13:"filter_html_1";i:1;s:18:"node_options_forum";a:1:{i:0;s:6:"status";}s:18:"drupal_private_key";s:64:"9847993438df6159fae73eaab241b1d82344060fe05aac3c1ffa2db02c3bfbc9";s:10:"menu_masks";a:28:{i:0;i:127;i:1;i:125;i:2;i:63;i:3;i:62;i:4;i:61;i:5;i:59;i:6;i:58;i:7;i:57;i:8;i:56;i:9;i:45;i:10;i:31;i:11;i:30;i:12;i:29;i:13;i:28;i:14;i:24;i:15;i:22;i:16;i:21;i:17;i:15;i:18;i:14;i:19;i:12;i:20;i:11;i:21;i:10;i:22;i:7;i:23;i:6;i:24;i:5;i:25;i:3;i:26;i:2;i:27;i:1;}s:12:"install_task";s:4:"done";s:13:"menu_expanded";a:1:{i:0;s:10:"navigation";}s:25:"drupal_http_request_fails";b:0;s:16:"language_default";O:8:"stdClass":11:{s:8:"language";s:2:"fr";s:4:"name";s in /homez.57/aloest/www/includes/database.mysqli.inc on line 128

Warning: Cannot modify header information - headers already sent by (output started at /homez.57/aloest/www/includes/database.mysqli.inc:128) in /homez.57/aloest/www/includes/bootstrap.inc on line 726

Warning: Cannot modify header information - headers already sent by (output started at /homez.57/aloest/www/includes/database.mysqli.inc:128) in /homez.57/aloest/www/includes/bootstrap.inc on line 727

Warning: Cannot modify header information - headers already sent by (output started at /homez.57/aloest/www/includes/database.mysqli.inc:128) in /homez.57/aloest/www/includes/bootstrap.inc on line 728

merci à ceux qui répondrons :)

Forum : 
Version de Drupal : 

j'ai le meme souci et il est impossible de modifier le my.cnf en mutualisé ovh, donc la valeur est à 1mo..et cela pose problème avec drupal au bout d'un certain temps...mais je n'ai aps encore résolu mon souci ,sinon que c'est le cron update qui bloque

merci pour cette info mais malgré l'activation du module je n'ai pas de page admin dédiée,j'ai fait les modifs au niveau du settings.php mais impossible savoir si cela fonctionne... as tu fais des réglages particuliers ? le cron refuse de s'effectuer par exemple

Salut Aiphes,

Je n'ai pas fais d'autres réglages que ceux du settings.php...
Pour savoir si le module fonctionne, tu peux toujours aller voir si dans sites\all\file, le dossier "cachefile" s'est rempli.
Je n'ai pas eu de pb avec le cron par contre... Peut-être que cela vient plutôt de la RAM de ta BDD.

De toute façon, pour ma part, cette solution n'a finalement pas réglé tous les problèmes.
J'ai du prendre un SQL Privé à 6€/mois de plus pour pouvoir augmenter le "max_allowed_packet" à 16M... Cher !!! satané module Views :P

Cordialement,

Thib

en effet il s'agit d'un souci de ram bdd, chez ovh mutualisé c'est limité à 1 mo...alors que j'ai besoin de 3 mo je pense,pas plus...du coup je migre mes sites les un aprés les autres vers alwaysdata qui offre 64mo de ram bdd, en mutu + le ssh (drush)...je crois que drupal en mutu chez ovh il faut l'optimiser à mort au niveau des requêtes sql, ce que je ne sais pas faire...

bonjour,
j'ai eu l'erreur 'max_allowed_packet' avec 500 lignes d'erreurs chez ovh sur un pack pro.
j'ai environ 80 modules d'installés.
J'ai du acheté un sqlprivé qui gère du coup toutes mes bases hébergées chez eux avec 128 mo de ram et j'ai pu augmenter 'max_allowed_packet' à 64 mo, redémarrer mysql ; plus d'erreurs.

quand à allwaysdatas j'ai pris un compte gratuit chez eux, ils m'ont envoyer 3 jours plus tard une factures de 95 €. je leurs ai répondu que je n'avais rien commandé et mon sorti le log d'inscription gratuit. je leur ai répondu que c'était gratuit et de là, grands seigneurs mon écrient qu'ils me repassaient en gratuit. ils sont à chier.