Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Impossibilité de dépublier un contenu

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,
Je suis actuellement en train de réaliser un gros site communautaire, dans lequel les utilisateurs peuvent ajouter des contenus de type différent.
Tous est sujet à une modération, donc les contenus utilisateurs sont initialement non publiés.
Tout fonctionnait très bien, ça fait trois mois que je suis en développement dessus et pas de soucis.
Depuis peu, j'ai remarqué que même identifié en administrateur il est impossible de dépublier un contenu, et les contenus postés par les utilisateurs sont directement dans l'état publié, bien que dans leur type de contenu respectif, l'état par défaut est non publié.
Sinon je n'ai aucun hook_nodeapi avec un $op à 'submit' ou 'validate' pouvant mettre à jour cette valeur du $node->status.

Quelqu'un aurait une idée ? Ou constaté ce caractère peut être à cause d'une mise à jour de module ou autre ?

D'avance merci.

Forum : 
Version de Drupal : 

Bonjour Selinav

J'ai un pb similaire : chaque jour je dépublie la journée de la veille dans une base contenant un planning d'occupation de salles. Ça fonctionnait très bien jusqu'à il y a 4 jours et ce depui 4 ans ! J'ai fait des modifications, mais pas sur ce type de contenu et je suis passé de la 7.44 à la 7.50. Est-il possible que ça vienne de là ? par ailleurs de quel "menu paramètres de contribution" parles-tu ? C'est dans "personnes -> droits" ? Dans la définition du type de contenu j'ai "paramètre du formulaire de contribution" dont le nom chez moi est "jour" et il était sur sur "Désactivé", je l'ai positionné à requis mais je ne peux toujours pas dé-publier des contenus de ce type.

Merci d'avance
Pierre