Problème avec views

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

J'utilise views dans mon site drupal et j'ai un petit problème.

J'ai créer une nouvelle vue (une nouvelle page) avec comme chemin : taxonomy/term/%
Cela fonctionne bien.

Ensuite, j'ai créé une seconde page avec comme chemin : taxonomy/term/%

La seule différence :
Ma première page : Node : Type = type1
Ma seconde page : Node : Type = type2

Ma page s'affiche convenablement sur mon node de type1 mais rien ne s'affiche sur mon node de type2...

PQ ?

D'avance merci,
Thibaut

Forum : 
Version de Drupal : 

je ne suis pas sur de saisir la question... tu veux dire afficher par exemple l'image pour un type de contenu mais pas pour tel autre, les deux étant listé par ta vue ? je ne vois pas comment faire ça sans PHP a priori...

Il y aurait une solution qui consisterait à créer deux champs différents (un field_type1_image et un field_type2_image) pour inclure dans la vue uniquement le champ présent dans le type pour lequel on veut l'image.

Il est peut-être trop tard pour ce cas précis mais l'idée servira peut-être à qqn d'autre...