Message d'avertissement

The subscription service is currently unavailable. Please try again later.

[Résolu] Page blanche après installation de la base de données

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

j'ai suivi le guide d'installation et là j'arrive à un problème.

J'en suis donc à utiliser l'installeur et c'est fait vu que mes tables sont créées.

Je poursuis le guide :
"Lorsque que l'on accède à notre site web pour la première fois, nous arrivons sur la page suivante.

Page d'accueil de Drupal lors de la première utilisation"
Et là, j'obtiens une page blanche.

Alors il m'a semblé lire à d'autres endroits que je devais modifier des pages .php (settings.php, conf ??) donc je suis allée voir dessus pour modifier $db_url.

Mais je ne sais pas bien quoi écrire exactement.

Pour info : j'ai voulu installer Drupal sur mon serveur NAS, et non en local (donc pas de localhost).
Mon arborescence des dossiers :
- dossier web/dossier mon_site/dossier_drupal
avec : index.php dans dossier mon_site/

Peut-être que l'erreur vient de là ? (cette page correspond à une page de site en cours de construction actuellement).

Un peu d'aide serait la bienvenue !

Je viens de recevoir un mail avec pour titre "account details" qui me dit de cliquer sur un lien menant à une page de mon site, sauf que j'ai une erreur 404 quand je clique sur ce lien ... :/

Version de Drupal : 

Dans le settings il faut mettre l'URL de la base ; généralement c'est localhost, mais ça peut être l'adresse IP du serveur MySQL

Pour les dossiers, éviter les espaces dans les noms, ça pourra aider aussi.
Est-ce que le serveur NAS fait serveur http ou est-ce que seuls les répertoires sont sur le NAS ?
Si c'est le cas, ça ne doit pas changer grand chose. Il faut aussi s'assurer que le serveur http pointe sur le répertoire de Drupal.

Tu installes sur quoi comme OS ? Windows, Linux, ?

Donc je dois mettre : http://@ipduserveur:5000/ dans le settings ?

pour les dossiers je n'ai aucun espace c'était pour l'explication simplement :)
mon serveur nas fait hébergeur de site web (deux sites web dessus, et je dois utiliser drupal pour le second site justement)

Je suis sous Windows XP et j'installe tout ça sur mon NAS (qui sont basés Linux il me semble).

En fait j'ai peur de ne pas avoir placé le dossier de drupal au bon endroit :/

Arborescence dans mon NAS :
- dossier Web général

dossier site 1
dossier site 2
------------- dossier Drupal
------------- index.php (page de site en cours de construction)

Pour le moment dans settings.php (et dans default.settings.php aussi ??) j'ai :
$db_url = 'mysqli://nom_user:mot_de_passe@localhost/nom_du_dossier_drupal';
Est-ce correct ?

Merci !

le db_url décrit les paramètres de connexion à la base MySQL, et n'a rien à voir avec l'arborescence.
La syntaxe est :

user:mot_de_passe@host/nom_instance_mysql

Il faut se souvenir du nom de la base MySQL créée lors de l'installation.

Question : comment fait le serveur NAS pour distinguer les 2 sites web ?
A moins de modifier les paramètres du serveur http, il va toujours pointer vers le même répertoire, non ?

Oui mais mon host c'est quoi alors ? C'est bien l'ip de mon NAS ?

Sur le serveur NAS il y a deux dossiers différents. Un pour chaque site. Quand on fera une redirection de type http://www.monsupersite.com, on redirigera vers http://@ipdunas/dossier1. Pour un second site http://www.monsecondsupersite.fr, on redirigera cette fois vers http://@ipdunas/dossier2.

Et ça suffit !

Pour le dossier contenant les fichiers Drupal, peu importe où il est placé ? (racine au même niveau que dossier1 et dossier2 ou dans le dossier1)

Le host, c'est l'IP de la machine qui héberge le MySQL, dont probablement l'IP du NAS.
Mais si il fait serveur http aussi, localhost doit fonctionner.

Pour le dossier Drupal, peu importe l'emplacement si la redirection pointe dessus, ça va aller

J'ai toujours ma page blanche =/

Je vais sur la page : http://@ipdemonnas/dossier1/dossierdrupal/index.php

Peut-être que ce n'est pas la bonne ?
J'utilise mysql et j'ai mysqli dans le $db_url. Je dois modifier ? Supprimer ?

Je dois bien avoir dans le dossier "sites/default" mes deux fichiers php default.settings et settings avec uniquement le fichier settings de modifié ?

Ma syntaxe : $db_url = 'mysqli://nomuser:password@localhost/nombase';

EDIT : dans le code source de ma page blanche j'ai ceci :

http://@ipdunas/dossier1//dossierdrupal/index.php
J'ai deux / qui se suivent, normal ?

Est--ce que tu peux créer un fichier info.php à la racine du dossier drupal, avec comme contenu :

<html>
<head></head>
<body>

<?php phpinfo();
?>

</body>
</html>

Puis essayer d'accéder à ce fichier php, via l'URL http://ipdunas/dossier1/dossierdrupal/info.php

Si ça affiche quelque chose, c'est la config drupal qui n'est pas bonne, sinon c'est un problème de serveur http qui s'embrouille ; ça permettra de voir d'où vient le problème.

Tu peux aussi regarder les logs du serveur http, si tu y a accès sur le serveur NAS (error log)

J'ai bien fait ce que tu m'as dit, et j'obtiens bien mes infos qui s'affichent !

Conclusion je dois désinstaller Drupal et réinstaller ?

Merci de consacrer du temps à mon problème en tout cas :)

Sinon qu'est-ce que "memory_limit" ? (phpinfo me dit que c'est à 128 M)

EDIT : ça me perturbe, je vois plusieurs fois comme url @ipdunas/dossier//dossierdrupal avec deux / au lieu de 1 oO

EDIT 2 : j'ai réinstallé Drupal, et pareil page introuvable. Je reçois un mail avec lien pour me connecter (lien unique ne servant qu'une fois) et en cliquant sur ce lien j'ai aussi une page introuvable :/

memory_limit est un paramètre dans le fichier php.ini, qui fixe la quantité maxi de mémoire utilisée par PHP. 128M, c'est déjà une grosse limite, on est plus souvent entre 32 et 64 Mo.

Pour le reste, est-ce que tu as pu accéder aux logs du serveur http ? sous linux c'est généralement dans /var/log/httpd ou /var/log/apache2 selon la distribution.

Je viens de regarder dans /var/log/ et je n'ai ni httpd ni apache2 !
J'ai : log.windows, messages, messages.0.gz, synoconn.log, synosys.log.

(j'ai regardé sur mon NAS, pas sur mon pc c'est bien ça ?)