Message d'avertissement

The subscription service is currently unavailable. Please try again later.

configuration du register_globals

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour,

J'ai un blocage à l'installation voici le message :

"La directive register_globals est activée. Drupal nécessite que cette directive soit desactivée. Votre site peut en effet être à risque si register_globals est activée."

J'avoue ne pas trop comprendre ce qu'il faut faire.

D'après ce que j'ai compris il faut changer une valeur dans le fichier .htacces

mais où et laquelle ?

Mon hébergeur est OVH

Merci d'avance pour votre réponse

Version de Drupal : 

Merci à vous de me répondre, j'avais déjà consulté la page http://drupalfr.org/node/5716 pour éviter effectivement de surcharger le forum.

Voilà tout ce que j’avais déjà fait car parallèlement , j'avais envoyé un mail à OVH et suivi les instructions qu’ils m’ont donné :

1 ) J’ai crée un fichier htaccess.txt en mettant juste la ligne :

SetEnv REGISTER_GLOBALS 0

et je l’ai renommé en .htaccess

Cela a donc supprimé l’original

Rien n’y fait, je recommence

2) Je garde le fichier .htacces comme il est et je rajoute un fichier texte dans lequel je mets :
SetEnv REGISTER_GLOBALS 0

Rien n’y fait, je recommence et fait autre chose :

J’ajoute :
php_flag register_globals off dans le fichier .htaccess tout au début des commentaires :

php_flag register_globals off
#

Apache/PHP/Drupal settings:

..................................etc etc

Rien n’y fait

Je trouve que le personnel d’OVH n’est pas très au point car voici ce qu’ils me disent :

« ou bien utiliser le htaccess de drupal qui a déja cette directive de désactivée:

PHP 5, Apache 1 and 2.

.
php_value register_globals 0
.
.
.
.

pour le htaccess de drupal je vous invite à vous rapprocher de la communauté drupal pour le configurer.

Je reste à votre disposition pour toute information complémentaire. »

Je suis un peu perdue et pas contente d’OVH

ou alors c’est moi qui ne comprends rien, si vous avez encore un peu de patiente pour m’aider

merci

Bonjour Alinea,

Je suis comme toi chez OVH, et j'ai depuis peu installé Drupal 7.
Je ne suis que novice, mais voici ce que j'ai ajouté tout au début de mon fichier .htaccess, et cela fonctionne sans soucis :

SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0
RewriteEngine On

En espérant que cette maigre contribution te sera utile.

Depuis 2009, elle a sans doute déjà trouvée sa réponse....
Y'en a qui sont vraiment fort pour remonter ce type de sujet (alors qu'une recherche sur google, donne aujourd'hui la réponse en moins de 30secondes), alors que d'autres plus récents, attendent encore....

Mais bon, on va dire que ce sera utile pour d'autres.... évidemment.