Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Installer Drupal 8 sur serveur OVH

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous,

Impossible d'installer Drupal 8 sur le host mutualisé OVH.

J'ai trouvé le message suivant :
- Votre serveur MySQL et le pilote MySQL PHP doivent supporter l'encodage de caractère utf8mb4. Assurez-vous d'utiliser un système de base de données qui supporte ceci (comme MySQL/MariaDB/Percona 5.5.3 et suivants), et que le jeu de caractères utf8mb4 y est compilé. Voir la documentation MySQL pour plus d'informations.
- La version 5.1.73 du pilote libmysqlclient est inférieure à la version minimale requise. Mettez à jour la version de libmysqlclient vers 5.5.3 ou supérieure, ou bien changez les pilotes MYSQL vers la version MySQLnd 5.0.9 ou supérieure.

Quelqu'un a la solution à ce problème, sachant que MySQL d'OVH par défaut avec l'encodage utf8_unicode_ci ?

Merci d'avant

Version de Drupal : 

Bonjour,
il semble que la seule solution, soit de demander à OVH un update de votre serveur, qui n'a pas l'air d'être très à jour.

Bonjour à tous,
Il y a quelques temps j'avais installé la version drupal 8 sur OVH (offre perso mutualisé). Cela a marché avec les versions de test, et les premières versions stables Drupal 8. Puis les prérequis Drupal ont été durcis, versions PHP, Mysql, aussi avec les problèmes déjà cités ici, encodage utf8-unicode..., et là plus moyen.
Aujourd’hui je veux enfin faire passer le site de mon association (site qui tourne toujours relativement bien avec drupal7 avec OVH), en douceur sur une version plus à jour, je veux donc essayer la dernière version, soit Drupal 9.0.2. Je prends un autre domaine pour essayer, en pensant que le temps aura fini par arranger les choses. Et là, grosse déception, grosse colère, avec un message d'erreur : "La version 5.6.48-log de votre serveur de base de données est inférieure à celle requise 5.7.8."
Je contacte le service client OVH, mail de retour : "Actuellement vous êtes sur une offre perso 2014 Mutualisé avec une version 5.6 aucune modification n'est possible sur cette offre. Si vous désirez utiliser une version 5.7, il vous faut commander une SQL privé; Si je ne m'abuse pas, cela coûte 4€ par mois, en plus de l'offre 43€ par an. C'est trop cher.
Drupal 7 n’étant bientôt plus maintenu, il n’y aura plus moyen de faire tourner un site Drupal sur OVH, Comment est-ce possible ? N’y a-t-il pas un moyen ? Est-ce normal ? peut-on faire quelque chose ?
Beve91