Message d'avertissement

The subscription service is currently unavailable. Please try again later.

Pré-requis pour l'hébergement de DRUPAL

Information importante

En raison d'un grand nombre d'inscriptions de spammers sur notre site, polluant sans relache notre forum, nous suspendons la création de compte via le formulaire de "sign up".

Il est néanmoins toujours possible de devenir adhérent•e en faisant la demande sur cette page, rubrique "Inscription" : https://www.drupal.fr/contact


De plus, le forum est désormais "interdit en écriture". Il n'est plus autorisé d'y écrire un sujet/billet/commentaire.

Pour contacter la communauté, merci de rejoindre le slack "drupalfrance".

Si vous voulez contacter le bureau de l'association, utilisez le formulaire disponible ici, ou envoyez-nous un DM sur twitter.

Bonjour à tous

Je poste des messages depuis quelques jours à porpos de l'installation de DRUPAl que je trouve assez génial. Sauf que je n'arrive pas à l'installer sur le serveur officiel de mon académie (Education nationale). J'ai fait un essai chez FREE et tout roule !
J'ai donc écrit au resppnsable en lui faisant remarquer que
Free utilise
phpmyadmin version 2.6.3-pl1
MySQL 4.1.15
le Rectorat utilise phpmyadmin version 2.6.4-pl2
MySQL 3.23.54.

Le responsable de l'hébergement reconnaît que MySQL 4 code différemment les mots de passe dans la base ce qui pourrait faire que l'authentification ne réussisse jamais. Mais il voudrait connaître les pré-requis pour l'installation de DRUPAL.

Qui peut m'aider ?

A mon avis, comme le precise alkahan a mon avis c surtout un probleme du a la version de PHP. J'ai une installe sur un MySQL 4 et un phpMySQL recent (2.6.3-pl1) et sur un MySQL 3 avec un phpMyAdmin plus vieux (2.5.3) et ca marche tout pareil.
D'ailleurs la version de phpMyAdmin ne va en rien influencer la maniere dont va fonctionner Drupal.

Le technicien me fait la réponse suivante je lui ai traduit approximativement la page citée par alkahan :
------------ début de la citation --------------
PHP a besoin des directives suivantes de configuration pour que drupal
fonctionne:
o session.save_handler: user
en outre, nous recommandons les arrangements suivants:
[b]o session.cache_limiter: none[/b]
j'ai testé ces paramètres pour les session mais cela empêche le fonctionnement
de toutes les sessions sur le site (DRUPAL, SPIP,etc...)
nous satisfaisons pleinement aux besoins de serveur (APACHE PHP ET MYSQL...)
je ne vois donc pas d'où le problème peut venir, si vous avez d'autres pistes, n'hésitez pas.
----------- fin de la citation.

Une piste ???

Capitaine Olivier

J'ai écrit ceci au technicien de mon hébergeur

Ce matin, message différent :

Warning: ini_set(): A session is active. You cannot change the session
module's ini settings at this time. in
/var/www/html/pedagogie/tice/80/sites/default/settings.php on line 109

warning: Cannot modify header information - headers already sent by (output
started at /var/www/html/pedagogie/tice/80/sites/default/settings.php:109) in

> /var/www/html/pedagogie/tice/80/includes/common.inc on line 99.

Et voici sa réponse
le problème viendrait donc du fait que le serveur est réglé en "autostart" pour les sessions et que donc votre application n'arrive pas démarrer sa session puisque le serveur l'a déjà fait.
Pour ce qui est de la solution du .htaccess, elle ne peut pas fonctionner car le serveur n'ait pas réglé pour utiliser les fichiers pour les sessions, le serveur s'en charge.

Je pense donc que cette application ne pourra fonctionner sur le serveur puisqu'elle demande des réglages trop différents de ceux nécessaires au fonctionnement des autres applications.

Qu'en pensez-vous ?

Capitaine Olivier

On peut toujours essayer. Autrement si on ne parvient pas à le faire fonctionner, il suffit de faire un rapport de BUG.

Essayes de commenter toutes les lignes ini_set dans le fichier settings.php

tu peux aussi essayer ça :

ini_set('arg_separator.output',     '&');
ini_set('magic_quotes_runtime',     0);
ini_set('magic_quotes_sybase',      0);
ini_set('session.cache_expire',     200000);
ini_set('session.cache_limiter',    'none');
ini_set('session.cookie_lifetime',  2000000);
ini_set('session.gc_maxlifetime',   200000);
ini_set('session.save_handler',     'files');
ini_set('session.use_only_cookies', 1);
ini_set('session.use_trans_sid',    0);

Merci de ton coup de main. Ca me réconforte quand je vois les réponses du 'technicien'

Bon j'ai modifié la ligne session.save_handler à 'files' et session.use_only_cookies à 1 mais RIEN !
J'ai essayé en variant 0 et 1 sur only_cookies et 'files' et 'user' sur save_handler mais RIEN !

Ce qu'il y a d'étonnant, c'est qu'il reconnait bien le couple identifiant/motdepasse mais rien se passe ensuite. En effet, quand on lui donne un mauvais mot de passe, le message d'erreur est différent...
Capitaine Olivier

Ce que je constate avec la reponse de ton technicien, c'est surtout qu'il te laisse pas trop le choix d'imposer tes propres reglages.
Deja le fait qu'il supporte pas les .htaccess c bizarre, mais si en plus tu n'as pas le choix qd a la modification des parametres par defaut de php, bin c pas gagne...
Le truc, c que je comprends parfaitement qu'il veuille pas toucher au php.ini mais au moins il pourrait te laisser le droit d'utiliser les variables ini_set ca ca ne changerai rien pour personne...